iBook G4 Grey screen

Discussion in 'PowerPC Macs' started by snatchblock, Jan 28, 2010.

  1. snatchblock macrumors newbie

    Jan 28, 2010
    I loaned my old iBook G4 to a friend, and it has been returned unuseable, can anyone suggest a way to go forward?

    When the machine is turned on I simply get a grey screen with a small file in the middle with an alternating ? and the finder picture (two faces). The chap that borrowed the machine fancies himself as a bit of an expert on mac, but is clearly not. He was apparently trying to "upgrade" the machine. But cannot "remember" what exactly he did!

    Any ideas would be greatfully received!
  2. Kim Philby macrumors newbie

    Jan 26, 2010
    It can't find a boot device. It either can't see the HDD or there is no OS on the HDD.
  3. snatchblock thread starter macrumors newbie

    Jan 28, 2010
    Not sure I understood that

    Hi, thanks for the reply, but I am not sure I understood it! I have tried to start the machine from a disc, whilst holding in the C button, with no result.
  4. Joewebster macrumors member

    Jan 20, 2010
    New York
    I don't get how you don't understand what he said. He said that either the iBook doesn't see it's hard drive, or Mac OS X wasn't installed.

    And to address your problem with the machine not booting from disk, I have no idea.
  5. California macrumors 68040


    Aug 21, 2004
    And what "disc" were you attempting to boot from?
  6. snatchblock thread starter macrumors newbie

    Jan 28, 2010

    I tried to "restart" the machine using the iBook G4 Mac OS X install disc. No joy.
  7. Kim Philby macrumors newbie

    Jan 26, 2010
    Okay - try this. Boot the unit and hold down the "option" key. Keep holding the option key until something shows up on the screen. At this point there will be 2 icons on the screen. The one on the left is a refresh button and the one on the right is the next or continue button. What will be displayed in between these icons are all the boot options the unit sees. If there is nothing there, then there is no boot device. At this point, you can insert a cd give it a few seconds and hit the refresh button and see if it shows up on the screen. If all you see is the CD then the unit is not recognizing the internal hard drive. if you see the internal hard drive and the cd then the unit recognizes them both as boot devices. Highlight the device you want to boot to and click the continue button. If the unit see both, then all is not lost and it's probably just the software on the hard drive. You can reinstall the OS from a CD to fix this. If the unit only sees the CD you inserted, ten the unit does not see the hard drive and you have to have it replaced.

    To boot directly to the CD, place a Mac OS system CD in the optical disc drive, press the start button and hold down the “C” key.

    Try these too:
    Reset PRAM (Press the power button, then hold down the Option-Command-P-R keys until you hear the startup chime at least one additional time after the initial startup chime).
    Reset the power manager by pressing the key combination Control-Option-Shift- power.
  8. snatchblock thread starter macrumors newbie

    Jan 28, 2010
    Thank you


    Many thanks for your clear and helpful instructions! They have fixed the problem.

Share This Page