iBook G4 Hardware (?) Issue

Discussion in 'PowerPC Macs' started by lewiguez, Oct 10, 2008.

  1. lewiguez macrumors newbie

    lewiguez

    Joined:
    Oct 10, 2008
    Location:
    Akron, OH
    #1
    OK. I've got a tough one (for me, at least)...

    I have an iBook G4 running 10.5. It's a 12" Late '04 model with the 1.2ghz processor and it has a stick of 512MB RAM, bringing its grand total to 768MB. In addition, it has 32MB of VRAM as part of the integrated graphics built into the logic board.

    The problem: The computer will run fine for a couple of minutes. It will boot up OK, let me login and let me onto the desktop. Eventually, after a couple of minutes, it will suddenly freeze. The beachball will come up and then it'll go away and the entire computer will be frozen. I can't move the mouse, I can't type on the keyboard -- everything is frozen. The only way out of it is to reboot the machine.

    What I Tried: I tried booting into safe mode, to no avail. I tried checking the logs and seeing what's going on in verbose bootup. It worked for a while in single-user mode so I thought it might a software issue with the OS installation. I decided that I was going to reinstall the OS again anyway, so I wiped the hard drive and reinstalled Mac OS (Leopard).

    Now, however, I can't get past the registration info on the setup assistant. I get to watch the opening video of the installation play (because it was successfully installed on the hard drive) and when I get to the textboxes to enter my info, the computer has the same freeze problem.

    I wanted to completely rule out software, so I tried booting up from a Live CD of Ubuntu. This did not work also. I ended up hanging on initialization of the graphics. I tried taking out the stick of RAM and running the Live CD, but the same problem occurred.


    I usually know what I'm doing when it comes to troubleshooting computers and fixing problems, but I'm honestly stumped. Does anyone have ANY ideas?
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    After that exhaustive bit of investigation that you did it looks like it's probably the GPU.

    I'd try it one more time without the additional RAM though.
     

Share This Page