ibook G4 (Late 2004) Troubleshooting Help

Discussion in 'PowerPC Macs' started by FinalCutJay, Oct 1, 2009.

  1. FinalCutJay macrumors member

    Nov 4, 2008
    My unibody MBP became my desktop, so i figured i'd dust off my ibook G4 1.33 MHZ for sitting on the couch and surfing the web. I was having problems with programs quitting and general Kernal Panics when doing just about everything.

    I reset the P Ram and saw no change. I thought maybe the OS was corrupt, so I reinstalled Leopard with no luck. It errored out during the install each of the 10 times i tried.

    I did a 32 pass zero out the data on the drive and tried reinstalling and still to no avail it failed. MAYBE it's my copy of Leopard? Well I went back to Tiger and got the same results. Ok so the hard drive has to be shot right?

    I sucked it up cause I really had nothing to lose and ripped the sucker open and replaced the HD. I tried Leopard again and it failed. Wrote Zeros to the drive and installed Tiger and voila! it worked.

    Well the excitement quickly turned into rage when the program crashing, and KP's came right back as they did before. WTF is wrong with this machine? Can anyone offer any suggestions or should i just let this sucker die?
  2. OrangeSVTguy macrumors 601


    Sep 16, 2007
    Northeastern Ohio
    Sounds like the memory could be shot. Try removing the memory to see if it stops the kernal panics. Installing both Tiger and Leopard ruled out a software issue. Replacing the HDD also ruled that out, only thing left is the memory. Give it a try and let us know the results.

Share This Page