ibook g4 loading login window freeze/ram problem

Discussion in 'PowerPC Macs' started by laikaisdead, Feb 24, 2009.

  1. laikaisdead macrumors newbie

    Feb 24, 2009
    This seems to be a very common situation with the ibook g4... but maybe someone has some advice for me since I cannot log in at all even with my ram problem.

    Doing the Hardware test i was given this error:

    2MEM/1/4: DIMM1/J31

    I have searched this code on google and it turns out to be a problem with my ram.
    The big problem is that when turning on my ibook, it shows the grey apple screen, loads to the loading screen. This screen loads everything except the last thing, which says "Loading Login Window".
    From that point on it does not continue.

    I have tried apple v, apple s, I have tried the apple option p and r. I have tried all the disks.

    Please, someone let me know if I am stuck and the only option is to go to the genius bar, or if there is something I can do on my own.
    Thank you!
  2. BlueRevolution macrumors 603


    Jul 26, 2004
    Montreal, QC
    Remove the memory stick. It's located just underneath the keyboard; all you need to access it is a #0 Philips screwdriver. If it works then (albeit more slowly), buy a new stick and you should be good to go.

    Be glad it's DIMM1 that's acting up rather than DIMM0. DIMM1 is the expansion slot, while DIMM0 is soldered to the logic board.
  3. slooksterPSV macrumors 68040


    Apr 17, 2004
    I would try reseating the RAM, in other words removing the keyboard, taking off the RAM plate, removing the RAM and making sure it securely snaps back on.
    After that I'd try this:
    1. Power on your Mac and BEFORE the chime hold down CMD + S (I think it is for single-user mode).
    2. WHen you get to the prompt where it shows # type in the following:
    sudo fsck -fy
    3. Restart your mac by typing in: sudo reboot
    4. Post back and let us know what happens

Share This Page