iBook G4 locking up issue tried everything

Discussion in 'PowerPC Macs' started by qnc, Jan 8, 2009.

  1. qnc macrumors member

    Joined:
    Jan 8, 2009
    #1
    Hi newly registered, but never had to before because search has always worked.

    Any way I have a iBook G4 1.33 768 MB Ram with a 40G HD.

    If left alone it will boot up no problem, but it will then lock up on me.
    If I power down and try to power it back up I get the flashing folder/?.

    Since I'm not a new to Mac I new it meant HD/Start up folder. I had a replacement available(computer parts pack rat)

    replaced the drive and started up ok but now the same issue. I replaced the drive again(third drive, i told you i was a pack rat)
    Same issue.


    I booted from firewire drive with same issue.

    I have tried Fsck, resetting the Pram and NVRAM. some one suggested that it was a powerchip issue and applying pressure to the ibook this did not work.

    I'm at a loss. The reason I know that the hard drives are good is because I tested them in my G4 powerbook and they run fine no issues no lock up.
    I'm posting from the powerbook right now.

    But I need my iBook, faster everything.

    All the information I found here has been great but nothing seems to work for me.

    The only thing I did not try was putting the board in the oven i don't have a forced air oven.

    any insight or extra hints would be appreciated

    thanks
     
  2. Skeletal-dæmon macrumors 6502

    Joined:
    Apr 27, 2008
    #2
    This may sound daft, but as you say you have been swapping out hard drives in the mean time...

    Take a cocktail stick, or drawing pin or something, and carefully clean the drive terminals inside the iBook. A bit of gunk on one pin can halt everything sometimes as I found with my Mac Mini and its mysterious vanishing RAM card...
     
  3. qnc thread starter macrumors member

    Joined:
    Jan 8, 2009
  4. bizzle macrumors 6502a

    Joined:
    Jun 29, 2008
    #4
    There isn't a "powerchip" in an iBook. What you're referring to is the graphics chip. They are prone to failure from poor BGA solder points. The pressure is reconnecting the chip, temporally. There are ways to put a shim in your casing to help keep it connected along with other DIY ways to resolve this issue.

    Regardless, that has nothing to do with your issue.

    What comes up when you press option when you boot the machine? Are you able to boot from any source, such as a firewire drive with a start up volume or an optical disk?
     
  5. qnc thread starter macrumors member

    Joined:
    Jan 8, 2009
    #5
    On power up (after a rest between 2 hours to overnight)if I hold down the Option button I can see my other bootable drives. Unfortunately I do not have the disk.

    I do have 10.3, 10.4 and 10.5 images on firewire drive and all will boot the iBook, but the iBook will lock up after about 40 minutes.
    After lockup and a hard power down, If I try to reboot again immediately I get the Flashing folder/? like no drive is available. So I wait another 2 hours or so and boots fine.

    I also can see the AHT disk when I press option. Tried this last night.(about 2am EST) When I try to boot from that disk I get Invalid Memory Access Error:

    %SRRO: 00032ed8 %SRR1: 0003030.

    I removed the ram and tried many more times, same error.
    At about 3AM I had to take a quick nap had to get up for work at 4AM.

    this is where I'm stuck at now.

    I appreciate all info and asistance.
     
  6. 4JNA macrumors 68000

    4JNA

    Joined:
    Feb 8, 2006
    Location:
    looking for trash files
    #6
    really sounds like a failing logic board to me. i've been fixing/supporting customers ibooks for years, and have seen several go out like this. i suspect that even though you didn't mention it, it would run much longer between locks when it started, and now the time is getting shorter between locks.

    long shot, and i know you mentioned pressure not fixing it already, what i have done on several occasions is use some extra pressure to get a system up, running and stable for an emergency fix or data grab. don't know if you have access to tools, but what i find the best is a pair of vise-grips, c clamp shaped, usually found in welding shops for holding parts together. i use a couple small pieces of plastic to spread out the force, and then apply pressure at the bottom edge of the keyboard, just left of the trackpad. i start with about finger pressure, or what i can do with my hands, and then slowly add a turn or so to the adjuster until i get a stable system. be careful to not put the pressure at the drive location, but just above it so you don't mash the hard drive. had one desperate student working on a paper this way with the ibook c-clamped to the desk for about 3 days, got the paper done, then removed the clamp and it immediately locked up.

    the failing BGA connection, as well as the cracked SOIC device joints cause all sorts of wacky problems, like the disappearing drive, as well as the boot and lock problem as described. just my 2 cents after spending lots of time fighting the same problem. best of luck.
     
  7. qnc thread starter macrumors member

    Joined:
    Jan 8, 2009
    #7
    Thanks, I have already used CCC to get all my data off the computer and keep a working image.
    Logic board, I did some quick checking man those are costly from what i have seen. maybe not looking in the correct place. I'll check in to a repair service or DIY and see what the costwill be and the best warranty I will get.

    On the other hand I may just have to give up. And find something new. I don't know if it will be worth fixing and then the issue may happend again.

    Thanks for the reply.
     
  8. mr.steevo macrumors 65816

    mr.steevo

    Joined:
    Jul 21, 2004
    #8
    Hi,

    I had a 933 iBook that did the same thing. Logic board was the problem.

    Just take it all apart and sell the parts for extra cash or use them in another iBook. Unfortunately that is about all you can do.

    s.
     
  9. qnc thread starter macrumors member

    Joined:
    Jan 8, 2009
    #9
    It appears after doing some more research. I will do just that. Looking at logic boards and services cheapest I found was 5 hundo. Might as well get me a new one.


    You all have been very helpful.

    Thanks
     

Share This Page