ibook g4 not spinning up hdd?

Discussion in 'PowerPC Macs' started by hansolo669, Nov 26, 2011.

  1. hansolo669 macrumors regular

    Joined:
    Oct 5, 2009
    #1
    the hdd in originally in the ibook was dead as a doornail, so i swapped the drive out for one of my (many) working IDE laptop drives. however when i boot from the osx installer cd distil doesn't show/detect any drives. on further inspection i found that the drive was not spinning up! pulling the hdd from the ibook and checking it confirms that it does indeed work, but when i put it back into the ibook and try to boot ... nothing, the drive just sits their.
    as far as i can tell their are one of two things going on here
    1: the orange IDE to motherboard cable is shot
    2: the on motherboard IDE controller is dead

    any ideas?
     
  2. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #2
    You may not have pushed the hard drive pins in enough. Just happened to me on an iBook.
     
  3. adcx64 macrumors 65816

    adcx64

    Joined:
    Nov 17, 2008
    Location:
    Philadelphia
    #3
    Also, make sure the orange cable is properly connected to the logic board.
     
  4. hansolo669 thread starter macrumors regular

    Joined:
    Oct 5, 2009
    #4
    just double checked, pins are pushed as far as they can go

    orange cable is connected securely and properly (and cleanly to boot!).

    considering that the ibook boots from the install dvd just fine, and everything appears to function correctly, I'm betting that the orange IDE cable is dead/broken/shot.
     
  5. adcx64 macrumors 65816

    adcx64

    Joined:
    Nov 17, 2008
    Location:
    Philadelphia
    #5
    do you see any small tears along the edges of the orange connector? I ran into a problem like this before.
     

Share This Page