iBook G4 printing problems

Discussion in 'PowerPC Macs' started by nextgenfx, Aug 13, 2008.

  1. nextgenfx macrumors newbie

    Jul 13, 2008
    I have a strange issue when trying to print to ANY printer whether it be a network printer or a locally attached USB printer.

    The machine is as stated, an iBook G4. The OS is OS X 10.4.1. The printers involved are a Sharp ARM450n, a Sharp MX 2300 both networked and a Brother hl5150d, connected via USB. All printers show up in the printer dialogue box as installed, all of the latest drivers are installed and when I attempt to print, the system claims it printed, no matter what printer I send the print job to. I just don't get any documents. The print jobs just vanish!

    I have searched on this forum for a solution, not to mention googling Mac printer issues on the internet. I have searched high and low for a solution with no luck.

    I've tried stripping out all of the drivers and starting fresh. I've tried resetting the print system, I've tried appletalk/ethertalk, I've tried bonjour, I've tried tcp/ip printing, all to no avail.

    All of the other computers (an assortment of approximate 35 different Macs can ALL print to the printers with this one exception. The computer is hard wired to the network and can access the internet, I can ping the printers, ping other computers and I can also ping the computer that is having the print issues.

    Any insight into this issue is greatly appreciated.
  2. SnowLeopard2008 macrumors 604


    Jul 4, 2008
    Silicon Valley
    upgrade the system to 10.4.11 that might help.

Share This Page