iBook G4 RAM upgrade: 512MB works, 1GB doesn't!

Discussion in 'PowerPC Macs' started by mj257, Jan 2, 2009.

  1. mj257 macrumors newbie

    Joined:
    Jan 2, 2009
    #1
    My iBook G4 (12", 1.33GHz, 512MB internal RAM) has worked perfectly with an add-on 512MB RAM module for years. At the time, I understood that that was the maximum amount of RAM that could be added. But recently I learned that it should be possible to install a 1GB module, for a total of 1.5GB. So I put in a stick of Kingston KVR333X645C25/1G (PC2700, 1GB, 333MHz, 200-pin SO-DIMM).

    Unfortunately, with the 1GB module in place, I found that the computer wouldn't even boot: no start-up sound, no white screen with Apple logo, nothing. Replaced the 512MB module, and it worked fine again.

    Sounds like a bad RAM module, right? But I had the vendor replace the RAM, and exactly the same thing happened with the new module.

    So, either (a) the vendor has a bad batch of RAM, (b) there's a problem on my motherboard which allows it to address 512MB but not 1GB, (c) I was misinformed (by several sources) about being able to add 1GB, or (d) ...?

    (Unfortunately, the vendor wasn't able/willing to try installing either of these RAM modules in another machine, and didn't have any non-Kingston RAM, either of which would have helped to rule out case (a). But at least they refunded my money!)

    Anyone else seen this sort of thing? Thanks in advance for any suggestions!
     
  2. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #2
    It could be mislabled ram like PC2100 that would not work in your machine.

    Ask him for a 200 pin PC3200 1gig chip that will be backwards compatible with your machine .
     
  3. mj257 thread starter macrumors newbie

    Joined:
    Jan 2, 2009
    #3
    Thanks, "California"! I think you were right: I tried a stick of Corsair VS1GSDS333 (PC2700 DDR 1GB), and it worked right off the bat. Cheers...
     

Share This Page