iBook G4 screen goes blank, has trouble restarting

Discussion in 'PowerPC Macs' started by zen, Aug 23, 2006.

  1. zen macrumors 68000


    Jun 26, 2003

    I've got an 800Mhz iBook G4 (640MB RAM, latest update for Tiger 10.4) which has worked without a hitch for the last 2 years.

    Suddenly it has started going dead while in use - the screen goes completely blank (although the backlights are still on) and all sounds cease. It doesn't matter if the machine is idle, or playing World of Warcraft, or encoding a DVD in DVD Studio Pro. It is completely random. The only way to get out of it is to hold down the power button to force it to shut down.

    Powering up is also becoming difficult - 9 times out of 10 the machine boots but I get no startup sound. Instead the screen stays dark and the fan goes on full throttle, and nothing happens. Sometimes I can force it to shut down by holding down the power button, sometimes I need to take the battery out.

    When the machine does boot and I get back into OS X, sometimes it displays a message saying my clock and time/date are set before 2001 and I may have problems. I understand this message comes up if you reset the power management unit, but on checking the time/date it is set correct.

    I have tried resetting the power management unit, but it doesn't make any difference.

    I have run the hardware test CD, and all items pass on the extended test.

    The iBook's battery is almost dead - this I know! But would that make any difference? With the time/date error that sometimes comes up on restart, it's almost like the internal battery that stores data like the time has run flat. Is this charged by the big battery?

    I haven't booted into open firmware, but I've read I can run the reset -nvram and reset-all commands from there (not sure what they do).

    Any ideas? It's not hardware, as the hardware test CD works. It doesn't seem to be a software error (although I haven't reinstalled OS X). Has my RAM gone bad or become unseated?


  2. disconap macrumors 68000


    Oct 29, 2005
    Portland, OR
    I have a 1gHz ibook from that same generation. I was having similar problems and did an archive/install of the OS (essentially it reinstalls the OS and transfers your user folder and settings over to the new OS) and it solved it, so I suggest doing that.

    Things you can do before that, though, are pull your RAM upgrade and try booting. Your stock RAM is 128, so Tiger might not boot at all, if it will it will take forever, but it's worth a shot, as bad RAM can cause that as well. But to me it just sounds like your system is a bit messed up, as those symptoms are, in my experience, rarely hardware related.

    BTW, my battery no longer holds enough charge to do much of anything but sleep for about 10-12 hours. So it's likely not that, but if you're worried you can try booting without the battery in (NOTE: do NOT remove or replace the battery while the computer is on).
  3. zen thread starter macrumors 68000


    Jun 26, 2003
    Cheers - I'll do an archive and install and see what happens.
  4. ITASOR macrumors 601


    Mar 20, 2005
    If you don't have a huge deal of stuff to back up, I would recommend erasing your HD and doing a clean install instead. This will make SURE that it is a hardware error and not an OS error. Since Archive and Install is putting some things that were there back, you can't be entirely sure that it will fix the issue.

Share This Page