iBook G4 shuts down when power cord turns red in color

Discussion in 'PowerPC Macs' started by JaimifaSF, Jan 11, 2010.

  1. JaimifaSF macrumors newbie

    Jan 10, 2010
    I need your expertise.

    My iBook G4 crashed on me one night, and the only way I could turn it on again was to unplug the power cord from my computer, turn it over, remove the battery, put the battery back in, plug the cord back into the computer, hold down the start button, and it would restart. Although, when it restarted, the fan would go on first, and then the computer would make the normal start sound. Some times the finder would be on the screen after I restarted it displaying a quick link icon of the hard drive. So after a few weeks, it did it again, then a few days, and then it got to the point where I had to keep my computer in the same position otherwise it might shut down.

    Now, if the power cord is green everything is fine, but if I move my computer and bump the cord into the wrong place it turns from green to bright red, makes an evil buzzing sound, and in three seconds the computer shuts off and I have to restart by using the method above. If or when the power cord goes bright red I do have 3 seconds to pull out the cord before it shuts down. I then sleep the computer, put the cord back into the computer, and move the cord around until it is green again.

    I took my computer to a mac genius, and when he looked at the crash report he said it was frequent, but not caused by the battery and couldn't tell me what was the exact problem. I bought a brand new power cord, but I still couldn't move the computer around to much or it would shut down.

    1.) Has anyone ever heard of this happening? And if so, what causes it to be so touchy?
    2.) What can I do to fix it myself?
    3.) If I send it in, will they be able to fix it so that it is perfect again without having to spend more than the money assessed?

    I would like to try to have it fixed. At this juncture, my only option is to send it in for $280 and hope they can fix the problem that no one seems to know what is the exact problem, or even where the problem stems from. I should add here that the battery is fully charged, and the report says it can hold about 1 hour of life, although it's more like 30 minutes, and then without warning to plug in or risk shutting down (like it used to give me) it will shut down.

    Thanks to anyone who read this whole post!

  2. jed65 macrumors newbie

    Feb 24, 2010
    Me too!

    Hi Jamie - I have exactly the same problem, with exactly the same computer. Everything you wrote is exactly describing my situation! I have been doing the same thing that you have to get the iBook to work. I had a really really old battery, so I replaced it, only to find the same problem happening (although I have to recharge the battery much less frequently). If you find an answer to your problem, could you please let me know (jed65@cornell.edu)? Also, I noticed that I am not able to fully charge my new battery now. I thought that maybe I have to reset the PMU? I didn't do this yet, as it erases all the RAM. Thanks for any help you can offer!
  3. Blo1124 macrumors newbie

    Apr 26, 2010
    Me Too!

    I am having the EXACT same problem as the two posters above! Just bought a new battery and was going to purchase a new power chord.

    Can someone (anyone!) answer this issue?
  4. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    I don't have an iBook G4 anymore, but I think a red light on the plug point is an indicator that there is a failure of some kind -- either the PMU or the battery or possibly the power supply (see link). If you're able to use the Mac on battery, though, that would suggest it's the PMU. You can try resetting the PMU as indicated here.
  5. Blo1124 macrumors newbie

    Apr 26, 2010
    THANKS for the response! I am not a very technical person but I think I can follow the intructions for the PMU reset. Other than the settings and possibly the date - will I be losing any other information when I perform this?
  6. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    I don't think you should lose anything as the result of doing a PMU reset. (As I understand it, the PMU settings are changed automatically by the system ... I'm being kind of vague about this, but what I mean is that I don't think the PMU firmware contains any user-defined settings, and so I don't think anything that you set is lost when you reset it at all.)
  7. Blo1124 macrumors newbie

    Apr 26, 2010
    THANK YOU!!!!
  8. ckingst macrumors newbie

    May 29, 2010
    Mac G4 Power failure

    Thanks for the info re red light/green light and battery failure. When I removed the battery, I could boot up again, and all is well as long as it is plugged into the power cord. When i put the battery back in (even with the power cord still plugged in), I get the red light and no go. Can the battery be recharged or do I need to get a new one?
  9. California macrumors 68040


    Aug 21, 2004
    Somehow bad batteries screw up the DC in Board.

    Live with it until you can replace the DC in.
  10. extendedremix macrumors newbie

    Aug 5, 2010
    I have a very similar issue with my iBook G4 12" 1,2 GHz as well.

    There seems to be a loose contact inside the iBook regarding power. Sometimes it just switches off suddenly with a nasty sound (no three seconds delay on my side). This happens no matter if run on battery or with the power cord plugged in. The light on the power cord switches to a bright reddish orange then. It's no clear red as you described. But the normal charging-orange is clearly lighter.
    This also happens sometimes when the computer is asleep.
    When the light is orange the computer will not react to pressing the power-button, also the battery is not charging. When I take it (closed) with two hands and really gently press it together the light on the power cord switches to green and then depending if the battery needs to be charged to normal orange or stays green.
    Only then I can press the power button and it starts.
    When it was (even shortly) in this state of orange-cordlight-and-no-reaction-on-pressing-power-button it forgot the date and complains that the date is set to before-1970. The automatic internet-time-feature the sets the date and time correctly and all is good.

    Things I tried:
    -Replace power adapter and cable.
    -calibrate the battery
    -let it without power and battery for one night

    Things I did not try:
    -Replace the battery (the problem seems to be unrelated to the battery because the problem occurs no matter if run with or without the battery connected.)

    What I want to try:
    -Replace the DC-In-Board. I heard (I am no technician) that the DC-In-Board is just responsible for the connection of the power cord, but the problem seems to be further inside the machine because it affecte the whole powering of it. So I am pretty unsure if it will do any help.
    -Look if there is a loose connection or a short-circuit somewhere inside

    If anyone had a similar issue and somehow resolved it - please answer in this thread and share your experiences! I think some users will gladly thank you - I certainly will!
  11. jed65 macrumors newbie

    Feb 24, 2010
    My solution

    Well, I spent a little $$ and purchased a battery (not made by Apple though - I think it was about $40), and that didn't solve my problems. So I then purchased a new adaptor made by Apple (about $90, but I heard the non-Apple ones are pretty poorly made) and it solved the problem. I think my old adaptor was just not supplying constant power surge or something. But, my iBook is back to working well. Hope this is helpful to any of you, although I know several things could cause the problems we are all having, so maybe my solution won't work for everybody?

Share This Page