iBook G4 Start-Up Problem

Discussion in 'PowerPC Macs' started by jacksonvillemac, Feb 5, 2007.

  1. jacksonvillemac macrumors newbie

    Feb 5, 2007
    My iBook G4 will not start-up. The screen comes up with the apple icon, the drive "churns" for about a minute, then stops leaving the icon on the screen. Using the iBook G4 Software and Install DVD, I ran the Apple Hardware Test and got an error message: Invalid Node/Rebuilding B-Tree. The repair, however, failed. I've tried transferring my files to my MacBook with a Firewire but the iBook G4 icon does not appear on the MacBook. My next thought is a more powerful disc first aid program. Any thoughts? This is my first problem with the iBook and I'm a bit stumped. Thanks.
  2. Gokhan macrumors 6502a

    Oct 7, 2003

    sounds like ur hd is toast you could try disk warrior that ight revive it long enough to get ur data off
  3. dukeman macrumors member

    Feb 5, 2007
    Hard Drive issue. You can try a copy of disk warrior or Norton util to fix the B trees, but to be certain, I would just upgrade to a new hard drive (7200 rpm will make a nice difference in OSX), Reload OSX and then throw your old drive in a mini firewire enclosure to get your stuff if disk util can fix it. and then use it as an external backup drive till it dies.
  4. jacksonvillemac thread starter macrumors newbie

    Feb 5, 2007
    Thanks everyone. Much appreciated. I was afraid it might be the HD and it was. Looks like I'm going to have to go to a MacBook sooner than I thought.

Share This Page