iBook G4 Trackpad not working after fresh install

Discussion in 'PowerPC Macs' started by Keithito, Nov 9, 2009.

  1. Keithito macrumors newbie

    Nov 9, 2009
    I just re-installed OSX 10.4 onto my old G4 iBook, and ever since I did the trackpad has stopped responding. When I plug in a USB mouse and check the system preferences under the keyboard/mouse panel I can't even see a trackpad listed, so it isn't being detected at all. I've tried re-installing the OS and it hasn't helped the problem. Ever since this happened The sound also doesn't seem to work anymore. I'm not sure what to do here, but it's pretty important that I get this fixed. Any ideas?
  2. macgeek18 macrumors 68000


    Sep 8, 2009
    Northern California
    I'm not sure either.i have the same problem with 2 of my ibook G3's.On my tangerine after installing OSX 10.3 the trackpad doesn't work and after installing OSX on both the speakers don't even work.I don't know either.:mad:
  3. OrangeSVTguy macrumors 601


    Sep 16, 2007
    Northeastern Ohio
    Are you using a Retail Tiger DVD or the Grey iBook discs?

    Strange that it doesn't even show up? Is it just disabled since you are using your mouse? There's a setting for that in system prefs if you have an external mouse either wireless or USB connected, it disables your trackpad.
  4. Keithito thread starter macrumors newbie

    Nov 9, 2009
    It's the retail Tiger DVD.

    I found that under the system profiler, I can see a trackpad listed as a usb bus device (which would make sense) and when I hold option and boot from cd, the trackpad works, insofar as it allows me to move the cursor to the boot from cd option, but upon installation is suddenly stops and displays a screen telling me that my mouse isn't turned on, and the cursor won't move until I plug in a USB mouse. I was thinking that maybe the copy of tiger just assumes I am using a desktop for some reason? I don't really know how to get around that one.

    And the speakers still aren't discovered even in system profiler.
  5. Ghostrelm macrumors newbie

    Aug 16, 2010
    I know this is kind of an old thread, but I just looked at it trying to solve the same problem. All you need to do is run software update, and update to the latest version of Tiger. I was using the retail cd too. Just update, and there you go! Trackpad and audio are back.
  6. Tennu macrumors newbie

    Apr 6, 2014
    What u mean usb mouse ?? Apple mouse some other ? Of i put my logitech usb mouse it doesnt work . Have sound but nothing else i cant to sh't
  7. jrsx macrumors 65816


    Nov 2, 2013
    Tacoma, Washington
    I found that updating software on my iBook G4 running Leopard worked well. The trackpad worked after a fresh install of retail 10.5.6, but randomly stopped working and the preference pane wasn't in System Preferences. After updating to 10.5.8 everything worked.

Share This Page