ibook g4 will not boot

Discussion in 'PowerPC Macs' started by Confused1, Aug 22, 2008.

  1. Confused1 macrumors newbie

    Aug 22, 2008
    I tried to use the disk utility to mount Leopard and install from an external hard drive thru the USB port. Once the installer came on, it asked to restart the computer. After restarting the computer, it stays on the apple screen. I have tried rebooting with a DVD as well as holding the option key. Someone help me please!!! It worked perfectly fine before I tried my little experiment.
  2. OrangeSVTguy macrumors 601


    Sep 16, 2007
    Northeastern Ohio
    You cannot boot from a USB drive on a the PowerPC iBooks. You can only boot through a Firewire connection. What are the specs on your iBook? Will it even run Leopard? How about installing Tiger on it?
  3. otis123 macrumors 6502a

    May 4, 2006
    if its the last rev of the g4 it will run leopard (im typing on one running 10.5) and it wont boot from a usb drive, the usb system isnt the best in the ibooks (need both usb plugs to get my ext HDD to mount)

Share This Page