iBook G4 will not install Leopard from partitioned drive...

Discussion in 'PowerPC Macs' started by HilleryOcsnally, Dec 28, 2010.

  1. HilleryOcsnally macrumors newbie

    Dec 28, 2010
    Brooklyn USA
    I have a PPC iBook G4 with 1.3 Ghz and 1 GB SDRAM that I bought new in 2006. I've never had a single problem with the machine, but it doesn't have a superdrive and the OS Tiger capabilities are limiting.

    Last year I upgraded to Leopard with a .dmg via FW external drive and loved the interface, but with only a 40GB HD I deleted any app I didn't need. Over the summer I bought a new iMac, but I still need the laptop whenever I'm away from my desk. I tried erasing and reinstalling now that I don't have to keep much data on the drive...interested in getting back those non-essential apps. I've done it before with the exact same resources, but this time it's not working. I'm hoping someone out there can tell me what step I'm forgetting.

    Here's what I've done:

    1. Connected iBook to iMac in target mode via FW and erased/partitioned HD in Apple Partition Format.

    2. Reinstalled Tiger on iBook from original disc.

    3. Connected iBook to external drive via FW and restored .dmg to smaller partition on iBook.

    4. Opened .cdr on smaller partition, saw the Leopard disc image, set the Leopard install disc as the startup disc in System Preferences. Hit restart button in System Preferences and got the little "not happeneing" noise.

    5. Went to desktop and opened the Leopard installer disk image and pressed the install/restart button there. Reboot was slow and dark at first, but ultimately booted Tiger.

    6. Went back to System Preferences, selected Leopard install disc as the startup disc again, locked the selection and restarted...booted Tiger again.

    7. Tried these tactics again while holding option key and then S key at restart, but the second partition with the installer was never recognized. Tried from Safe Mode, only booted Tiger.

    8. Then I tried connecting the external drive again and opened the .dmg, then .cdr from there. Again System Preferences recognized the installer, but it would not boot with the same variables as before.

    9. I connected the iBook to the iMac in target disc mode again and ran disc utility, all good. Then I did same with external drive, all good. I made sure both drives and the install disc image were bootable. Tried the boot again from both, all bad.

    10. I did a lot of reading on troubleshooting this process and thought it might be a permissions problem, that the installer was not executable. I did a terminal tutorial and managed to make the partitioned drive and disc image both owner enabled. Still the exact same results as when I started.

    I've done all I can on my own, but I'm out of my depth. Can someone help?
  2. Hrududu macrumors 68020


    Jul 25, 2008
    Central US
    So can you not use your iMac to burn the .dmg to DL-DVD and then just install it on the iBook from there? Any iBook with a 1.33GHz processor has at least a combo drive which will read a DVD. I guess i'm having trouble understanding your process here. It seems far more complex than necessary.
  3. HilleryOcsnally thread starter macrumors newbie

    Dec 28, 2010
    Brooklyn USA
    I thought you could only get 4.7 on a DVD, but I just looked up DL-DVD and Hooray! Yes, that is much simpler. Thank you!!!!!!!

    When you have a computer without a superdrive for 4+ years you're not exactly up to date on the media.
  4. HilleryOcsnally thread starter macrumors newbie

    Dec 28, 2010
    Brooklyn USA
    DVD-DL Arrived...

    And disc utility says it's not big enough, but really it is. The .DMG is 7.66 GB and the disc says it's capable of 8.4 GB. Is there something I'm supposed to do to make the iMac recognize the format?

Share This Page