iBook G4 won't boot beyond blue screen.

Discussion in 'PowerPC Macs' started by RPP, Dec 13, 2007.

  1. RPP macrumors member


    Aug 13, 2006
    Melbourne, Australia
    As the title suggests ..

    After installing an app ('Detour') I was asked to (or it was suggested that I should) restart my computer. I did so, and now my 1.33GHz iBook G4 turns on - but it will not go any further than a blank blue screen (after the initial grey screen that appears.) Thankfully, all my data is on an external drive. I keep my music and footage which I have shot on there amongst other things. I also have a backup on my external via Time Machine of all my data which I keep on the iBook drive, so nothing should be lost.

    My question is whether I can restore my computer to how it was before all this happened (and what is the best way of doing so) or whether this is a sign that it's dying. Share similar experiences.
  2. WildCowboy Administrator/Editor


    Staff Member

    Jan 20, 2005
    Have a look at this article for some hints on things to try. It's an old article (depending on which OS you're using), but most of the hints still apply.
  3. bew macrumors newbie

    Sep 26, 2010
    Boot into Safe Mode (hold down Shift key at start up)

    Go to System/Library/Extensions and delete all files with ATI 9700 in the name
    I copied new files from another machine just to be sure.

    Problem solved.

    Something to do with 10.4.8 upgrade. Lots of other 'solutions' on the net but none seem to have worked. This resolved my stuck iBook 1.42ghz.

Share This Page