iBook G4 won't boot past apple screen & no CD boot

Discussion in 'PowerPC Macs' started by P-S-3, Jun 11, 2007.

  1. P-S-3 macrumors member

    Aug 28, 2006
    I have an iBook G4 1.07 GHz 30 gb 256 RAM with Panther. It was working fine until my HD got close to being full. Now I can't get it to boot past the Apple screen. It will either freeze there, or move on to the blue screen and freeze before the progress bar enters. I want to re-install Panther but I can't get any CD to boot during startup by holding "C", including the Panther OS CD, the Hardware Test CD, or the Tech Tool CD. I am able to boot to single user mode, where I type fsck -fy, and I recieve no errors with the hardware. I had this issue beore and my HD had to be replaced by Apple. I think my warrenty is now up so im looking for advice.

  2. darwen macrumors 6502a


    Apr 12, 2005
    California, US
    There is another command that allows you to boot from the CD. I thought it was holding down option instead of c but I am not sure. I cant test it now because I think they removed it on the intel computers. I used to do it all the time on powerbook though. It is a command that allows you to choose the CD drive or any of the hard drives to boot from. Kinda like how boot camp lets you choose windows or os x. Hence why boot camp replaced the key. Sorry if this does not help.
  3. Aniej macrumors 68000


    Oct 17, 2006
    to try and isolate the issue, what caused you to need to do this in the first place or did it just sort of happen?
  4. Plumbstone macrumors regular


    Feb 6, 2007
    It still works, hold down alt during the startup chimes and keep it down until you get a choice of systems to boot from. It will find every bootable OS on your system, click on, or Tab to and hit return, the one you want.

    If your drive is really full you may want to get some files off, if you have access to another mac use taget disk mode when booting and copy off some data.
  5. Btroisi13 macrumors newbie

    Feb 22, 2008
    Near Boston, MA
    I am having the same problem too!

    I have an iBook G4 1.07 Ghz 512 MB RAm and a 30 GB Hard Drive with Panther. When I boot it up, I hear the bong sound, then it hangs at a blue screen for about 1 minute. Then it shows a blinking question mark Folder icon, and then shows a folder with a picture of the Finder face.And when I hold down option at startup, it shows no hard drives to boot from, not even any CDs! I think I hear the hard drive running if I put my ear up to the keyboard. Then it goes right back to the question mark folder again and loops like that forever! I cannot get into Target disk mode, Single User mode, or Verbose mode. I can get into Open Firmware, but I cant really do anything from there. Resetting the PRAM does nothing, reseting the PMU didnt help. When I boot from a panther CD, it goes to the Apple Logo screen, and after 5 seconds, the Apple logo shifts to the right and down, leaving pixiliation where the logo used to be. It just hangs there. After 2 minutes you cant even hear the CD being accesed anymore! I tried to test the CD by booting an eMac with it, and it booted quick and perfectly! I have no idea what is wrong! Can someone please help?

    Thank you!
  6. klaauser macrumors newbie

    Dec 21, 2008

    I'm having the SAME exact issue

  7. 13scott macrumors newbie

    Dec 16, 2008
    part of the problem is your hard drive

    The Flashing folders mean that you need a new hard drive, as for the rest of your problems I have no idea.
  8. itmaximum macrumors newbie

    Nov 1, 2011
    ibook wont boot to any device

    Hello, I have an Ibook as well, the drive was replaced when the previous drive died, but I am unable to boot to any OS CD's in order to install a new operating system, it just boots to the ? in a folder icon, hitting C does not boot to the original Ibook install CD, nor the other 3 OS-X cd's I borrowed from friends to try out. if I hold down the option button it does eject CD's, but I thought the cdrom might be bad and purchased a new superdrive, installed it ... no change

    any idea's?
  9. tom vilsack macrumors 68000

    tom vilsack

    Nov 20, 2010
    ladner cdn
    i have had issues with past ibooks and some of these worked

    -would not book from "c" but would boot using "option" but only if from cold boot (unplug for a few min then try option boot)

    -if borrowed osx cd/dvd that were burned from windows computer would not boot...tryed making image of cd/dvd in a working mac and then burning image using mac....then tryed booting in ibooks and would work

Share This Page