ibook having issues connecting to WEP ap

Discussion in 'General Mac Discussion' started by mwdmeyer, Jan 5, 2005.

  1. mwdmeyer macrumors member

    Dec 23, 2004
    Sydney, Australia
    I'm having problems connecting my ibook to the wireless network here at work.

    I have a wireless setup at home with WPA and it works great. Here at work we have two different access points, a Zyxel B-3000 and a Linksys WAP54g (I think). They're both setup to use WEP 128bit. The keys are manually entered and key 4 is the active one.

    Now I can logon to the wireless if I type in key 1 but there is no data transfer. Keys 2,3 and 4 just say that it is incorrect and I cannot connect.

    There are windows XP laptops working on the network (with key 4) and my laptop could connect when the linksys was in WPA, but we need to use WEP.

    It seems to be a problem with my ibook, although WPA works fine. Any ideas?

    Running 10.3.7
  2. Mechcozmo macrumors 603


    Jul 17, 2004
    Sometimes Apple's cards don't play well with other routers when security is on. Just have to accept it and find a workaround... but why can't use use WAP? It is more secure...
  3. mwdmeyer thread starter macrumors member

    Dec 23, 2004
    Sydney, Australia
    Not all the devices support WPA, plus the guy here doesn't want to change all the laptops etc.
  4. DougJrS macrumors regular

    Mar 21, 2004
    Kansas City
    I don't know if his will apply, but I spent 5 hours trying to get my Airport Express to work with my WAP54G. Finally I rememberd that the MAC address filter was on. After I disabled that feature it worked fine. (Once the MAC filter was off it was about 5 minutes before I was printing)

  5. gekko513 macrumors 603


    Oct 16, 2003
    Have you tried to change to use key 1 as the active one?
  6. Westside guy macrumors 603

    Westside guy

    Oct 15, 2003
    The soggy side of the Pacific NW
    A lot of older wireless cards just plain don't support WPA, unfortunately - it needs significantly more horsepower than WEP does.

    If you haven't talked to whomever manages your network, I'd suggest doing so. It probably won't help (in which case you're out 5 minutes); but if someone else has had this problem and they managed to resolve it, then you can save yourself some time and grief that way.
  7. SiliconAddict macrumors 603


    Jun 19, 2003
    Chicago, IL
    I spent about a day working on getting a friends iBook on my WIFI network. The fix was to not use key 4, 3, or 2. I don't know if you can somehow use a key other then key #1 but in any case I move him to key 1 and life was good. If possible try using only key one and as someone else said check and see if your network has MAC filtering on. Also if you have an IT staff, as a IT pro myself, I think they would appreciate it if you would run it past them before connecting your personal hardware to the network they admin. Think of it as asking your neighbor if you can park in their driveway before actually doing it. Basic common courtesy. That and I've been know to pull a quickening on a person who just brings their own "stuff" from home and connects it to my network. In all likelihood it usually isn't a problem its that one time out of one hundred is what I have issues with. :)
  8. mwdmeyer thread starter macrumors member

    Dec 23, 2004
    Sydney, Australia
    Thanks for all the input everyone.

    It isn't MAC filtering and it seems just to be the fact that we're using key 4 and not key 1.

    I am one of the IT staff people, but I manage the windows servers. So I wasn't too sure about the wireless on the mac.

    Anyway thanks for all your help.

    Since the mac can only use key 1 it looks to be a problem with either the mac software or hardware. Do we know if there is going to be a fix for it?

Share This Page