iBook + OpenSUSE 11.1 - anyone tried?

Discussion in 'PowerPC Macs' started by slooksterPSV, May 3, 2009.

  1. slooksterPSV macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #1
    I have an iBook G4, still have it after what now... 4 years, it's the last gen. 1.33ghz 512mb (uped to 1gb) 40gb hdd etc. etc. etc.
    Well I see that Novell OpenSUSE still supports the PowerPC architecture, and OS X, without it being updated or having an intel chip, a lot of the apps I wanna use just won't work well unless it has an intel chip in it (or its not a universal app). Anyways my question is, has anyone tried OpenSUSE 11.1 and if so does it pickup on the broadcom chipset for the wireless and enable wireless on the mac? If you could let me know that'd be great.

    thanks

    --SB

    P.s. if I get this new job I'm buying a new mac.
     
  2. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #2
    I'm not sure whether or not OpenSUSE ships with them, but most (all?) Broadcom chips have some form of workable driver support under Linux.

    I'd stick with Ubuntu personally, since their "we don't care if it's not FOSS" stance towards drivers means that it's usually easy to get it up and running on otherwise-troublesome hardware.
     
  3. knutux macrumors newbie

    Joined:
    Sep 12, 2009
    #3
    wireless working on iBook with openSUSE

    I 'm now in process of installing openSUSE on my iBook. There were some issues:
    • some workaround needed during instalation as normall instalation "fails to mound dvd"
    • I was unable to correctly setup boot loader, so now I am now using instalation dvd to boot installed system (hopefully I will resilve this issue)
    • Wireless setup was painfull, but after some reading and trying I do have a wireless connection working (needed to download firmware and some other magic stuff)
    • Everything works much slower than Mac OS X 10.4, but maybe that's just a configuration issue
    • I still need to tune track pad, keyboard and power management
    ,
     

Share This Page