ibook refuses to boot after installing leopard

Discussion in 'macOS' started by RedTomato, Oct 2, 2008.

  1. RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #1
    Hiya

    I have two ibooks (1.33ghz, 512mb ram) and a brand new Leopard family pack DVD (carries 10.5.4) from the Apple store.

    Installing Leopard on the first one went like a dream, no issues. It's working fine now.

    The second one has been a nightmare. Did an erase and install then:

    1. verify DVD failed

    2. cleaned DVD and retried. Passed verify.

    3. Install failed - couldn't find a file. Cleaned DVD and retried.

    4. Install hung - showing 3 hours to go and hung.

    5. Reset PRAM on the iBook and tried again. (erase and install)

    6. Deselected all the optional installs for just a core-only install.

    7. Success! Successfully installed (45 minutes), with success message on screen.

    8. Reboot failed - showed grey screen with apple logo and spinning circle for 30 mins.

    9. Rebooted with the Leopard DVD and repaired permissions on the HD (a few permissions repaired) and repaired the HD (no errors reported).

    10 .Still boot failure (stalls on grey screen with apple logo and spinning circle.)

    11. Reset PRAM and tried booting again. Still boot failure as in 10.

    Help me please, I've spent two days trying to install Leopard on this iBook :(
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    I'm guessing hardware failure, either optical drive, hard drive, RAM, logic board, or some combination of those. Try installing an older software version just to see, but I'm thinking you'll want to take it in for service (or write it off if it's not worth that much to you).

    jW
     
  3. RedTomato thread starter macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #3
    Thing is, it was working 'almost' fine in tiger before the attempted upgrade.

    working = 10 hours day of heavy use, internet, quark, myob, office etc

    almost = refuse to connect to networked printer, and occasional freezes when overheating.

    You could be right about the hardware problem. I'll try going back to tiger if all else fails.
     
  4. RedTomato thread starter macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #4
    OK so now I've erased the HD and gone back to Tiger. Using the original Tiger discs, Tiger installs perfectly without a hitch.

    Setting up accounts, shutting down and rebooting all goes well.

    However, all is not good. Safari refuses to launch. And if I try to download the combo updater to update it from 10.4.3 (on the DVD install) to 10.4.11, the updater stalls halfway through the expansion part.

    If i force quit the updater, the iBook still works, but on the next shutdown, it will fail to reboot. It freezes on the grey screen with apple logo (but with no spinning gear). The only way out seems to be to reinstall Tiger.

    This is an iBook that was happily running 10.4.11 yesterday :(

    I'm now on my third reinstall of Tiger, and I will try just updating it to Leopard without trying to apply the combo update. If that fails, then i will have to leave it on 10.4.3 and never update it. :( :(
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #5
    A= good install
    B= problem machine

    If the iBooks are identical, you can do target disk mode,

    boot using optical on A
    B attached target disk mode

    Open disk utility,
    erase B and restore contents of A onto B.
     
  6. RedTomato thread starter macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #6
    OK thanks - I'll try that. I don't have access to machine A till next week (it's been borrowed for the weekend).
     
  7. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #7
    I really don't know if I'd try to run Leopard with only 512mb of ram.

    it was slow on a G5 I have with one full gig.

    Max out those iBooks. Throw in bigger faster hard drives, too. You are stressing those slow little hard drives with so little ram...

    Also, are they 12" or 14" ibooks? The 14" 1.33ghz only can take 1.25ram. the 12" 1.33 can take 1.5gbs of ram.
     
  8. RedTomato thread starter macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #8
    They're 12''. I already said at the top that they have 512MB ram each. iBook A (the one with the perfect install) now has 1.5GB in, and is working well.

    The main reason for Leopard is to get them working with our Time Machine setup.

    Replace HD? I don't bloody think so. I tried extracting a HD from an iBook with a dead video card about a month ago, and it was a bloody nightmare. I accidentally ripped off the mobo power connector (even though I already knew it was a weak point), completely bricking the iBook.

    For us, 60GB is fine anyway. It's almost the same as you get on a brand new MBA :rolleyes:
     
  9. RedTomato thread starter macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #9
    Well I got it working now.

    For anybody who's still reading this thread, here's how.

    After seeing reports of other people succeeding via the 'Archive and Install' method, I tried it. Success!

    1. Install 10.4 Tiger.

    2. Don't run any updates. (I ran disk verify and permissions repair, but if they crash too, you could leave them out too.)

    3. Used the Leopard DVD to run Archive and Update (not Erase and Install, and not 'Update')

    4. I kept "Preserve user and network settings" ticked. Because the ibook was able to boot under Tiger, hopefully keeping these settings will enable it to boot under Leopard. (An apple technote says it does more that just keep settings, it also preserves many of the boot-up files from the previous installation)

    5. Success! Once I'd tested Leopard by rebooting a couple of times and running Verify and Permissions repair, I tried out installing some updates. I took it slowly, and only let it install one update at a time, starting with the combo to take it to 10.5.5, then when that was finished and rebooted, letting it run the Java updaters etc.

    It's now happily working as an office production machine with 1.5GB Ram.

    I have to say, I'm impressed with how well these 3 year old laptops work with Leopard with enough RAM.

    I can't see a 2005 Dell laptop with a Pentium M 1.5ghz working so well with Vista. I'm sure someone will prove me wrong soon.
     

Share This Page