iBook Won't Recognize DVD player, but plays CDs

Discussion in 'PowerPC Macs' started by kirk wilson, Jun 6, 2008.

  1. kirk wilson macrumors member

    May 18, 2008
    Hi to everyone..

    Part of my iBook says there is an initialization error when I open up the
    DVD program, and the other part of it says I have have no drive at all.

    I posted this a long time ago, and can't find the post. But I have tried everything that I was told to do. Basically I have a problem with my white iBook Laptop, a G3-4 800 mhz, which
    runs on OSX-10.14.11, and has 384 sd-ram

    It has a DVD application program, but opening it just gives an initialization error. The date on the App is something from earlier this year, so it's not that old. It has the corporate "DVD" player logo. (but it won't open)

    If I drop down the Apple menu at the top corner, "About this Mac"
    I see the list, and if I select Burners, it says No Burner Found.
    If I look for CD or Audio devices, there is nothing like that on the list
    but i can find the cd drive under ATA drives (it has the HD listed, and then a CD drive).

    When I open Disk Utility to find out about 'repairing disk permissions'
    all I see on the left side of the screen are 2 drives: the hard drive
    and a CD drive (LG Model 8245B), and I cannot select 'repair permissions'
    or 'verify' because they are in light grey (un-selectable). If I click
    on 'First Aid" bacically nothing happens. It's sort of like "nothing's broken, nothing to fix."

    So I went on to reset the PRAM, as this was the last suggestion
    someone gave me. It didn't do any good.

    Some interesting things: The thing plays CD's. It detects a CD drive, like I said. There is no CD/Audio player Application, anywhere (i was looking
    to see if it was read/write).

    There is also, buried somewhere, an older Apple DVD application, for an Apple DVD player. It wants to run on OS-9. So I open OS-9, and after OS9 has opened, it tells me that OS-9 doesn't support it.

    The DVD application I mentioned earlier (it's about 28 MB) is newer, and runs on OS-X 10.14.

    (So.. yes, this was an OS-9 computer which got upgraded to OS 10.4.11)

    Lastly, it came from a brother in law who is a filmmaker, and I know
    that he used it for DVD's. I was told i could also burn with it.
    (it doesn't burn cd's right now)

    He re-set some names and passwords when he gave it to me; from what I can see, all the 'permissions' are ok, and set to my name. I have his passwords in case I need them.

    If the computer has forgotten that it has a DVD drive, then I can't run
    OS 10 (which is a dvd), if it were to crash. This worries me, since I had
    to do this with my old Pismo only 2 months after buying it (at least it had a dvd drive!)

    I lifted the keyboard to see if there was a label on the cd-dvd player.
    Nothing. I can't pull it out (like I could in my old Pismo) to examine the underside. How does it come out? (it's a tray-loader)

    Before I start trying to remove the drive, just to see what it says...

    Is there any program on the iBook which will actually detect, and tell me
    what hardware I have? I think that the computer still thinks it has the old
    cd drive in it, even though it was obviously upgraded to a dvd drive.
    If I could find out the brand I could maybe download some software driver
    for it..? Maybe?

    (i am sort of afraid to go poking around the system files if I know that I cannot use the OS- 10 startup disk when it crashes (since it is a dvd)...

    So is it beginning to sound like there WAS a dvd drive in there first, which burned out, and was replaced by a cheaper LG (that's Dell) CD-R drive?
    Say it ain't so....

  2. techound1 macrumors 68000


    Mar 3, 2006
    If it's a tray load, you have a G3 iBook.

    Physically looking at the drive involves removing the white plastic covers and the aluminium shields. Not hard; not for the faint-of-heart. ifixit.com has free instructions.

    System Profiler (apple in the ULH corner, click on "about this mac") will tell you what it's got for a drive. You will also see an item there called "disc burning" and you can look there for info on, well, disc burning.
  3. kirk wilson thread starter macrumors member

    May 18, 2008

    i think it's solved.

    tried to detail it, butI had to log in three times, lost the post three times, so i'll try
    again some other time.


    now... will this one post?
  4. swest macrumors newbie

    Jun 12, 2008
    Make you iBook recognize the CD/DVD tray

    To make my iBook re-find my CD/DVD tray, I go to the Startup disc options in System Profiler. Select the OS9 folder to set the computer to startup using OS9. Then restart your computer. You should hear the CD tray kick-in. The screen will show the "file ?" symbol, if you don't have your computer set to start up in OS 9. Hold down the start button to shut down your computer. Restart holding down the Apple + X keys. Again, you should hear the CD tray kick-in when OSX mounts.

    I don't know why this works, but it does. There must be some issues with OSX and Classic on the iBook.
  5. tuxtpenguin macrumors regular

    May 19, 2007
  6. swest macrumors newbie

    Jun 12, 2008
    The problem solved

    Periodically my iBook will not recognize the CD/DVD tray. I have had a CD in the tray and everything will be working fine, then I'll put another CD in the tray and nothing happens. Even the eject button doesn't work. If I just reboot, I can hear that the CD tray never engages. By doing what I state above, rebooting in OS9 followed by rebooting in OSX, somehow my computer will then recognize the CD/DVD tray and everything works fine.
  7. kirk wilson thread starter macrumors member

    May 18, 2008
    that was scary..

    I tried what you said.. re-started in OS-9 (although there is no startup
    disk option in System Profiler, but there is one in System Preferences).

    It re-started, then it wanted to walk me through the whole registration process
    for OS 9.2.... name, address, date of birth, etc. I don't want to do that.
    It would not let me out of it. So I forced-quit, and it re-started again ...
    in OS-9, again, with a warning, and it took ten minutes to re-examine the HD for errors. Shame on Me for incorrectly shutting it down! (remember those days?)

    Anyway, it finally opened with an ancient OS-9 desktop, I selected DVD in the Apps file, and it said 'error in initializing..'

    Then I selected Apple DVD in the hardware
    list, somewhere, and it said This Mac does not support DVD player.
    I popped in a dvd (using a paper clip) and went to i-tunes, and no
    disk was recognized.

    I dug up OS 10.4 somewhere in the files, and re-started.

    I still have OS-10.4... I still have my songs, my files.. I thought I had lost them forever.

    I don't have an OS-x 10.4 startup disk, so if I lose my stuff i am back to OS-9.2 forever.

    So, the answer that I had before, to this problem is that my computer says I have an LG Model Blah-blah-blah CD-Rom player, and that's that.
    I figured that the DVD Program in the APPs folder somehow relates to an external drive which was not given to me when I got the computer.

    I am out of the country and if I go poking around this machine and I lose everything I have with no way of restoring it. So I'm leaving it alone.

    The cd-rom will make sounds on startup with a cd in it. But not with a dvd in it.

    So, I'm staying away from OS-9, for a while at least. It's kinda grey-looking.


Share This Page