iPod touch iBooks and Music on 2G iPod Touch??

photonwhiz

macrumors newbie
Original poster
Jan 19, 2012
3
0
This is my first post on MacRumors, so I hope I'm putting this in the right place. I have an 8 GB 2nd-generation iPod Touch (model MC086LL), loaded with only about 4GB of assorted apps, music, iBooks, and photos, and running IOS 4.2.1.

Until recently, I've been able to enjoy reading books in iBooks while listening to music, but ever since I "upgraded" iBooks to Version 1.5, this feature seems to have been taken away. I can launch Music and get a song going, but as soon as I launch iBooks, the music fades out and never comes back. This hardly seems like progress! Music still multitasks with other apps, including a number of games, but no longer with iBooks. Is there any way to get back the ability to use iBooks and Music at the same time?
 

photonwhiz

macrumors newbie
Original poster
Jan 19, 2012
3
0
Thanks for the suggestion about double-clicking the Home button (after I start Music and then open up iBooks); it may work on an iPad, but I can't get it to work on my iPod Touch -- all it does is to close iBooks and take me back to the Home screen with all my app icons. If I then manually re-open Music, whatever song had been playing before I opened iBooks is paused, and can be restarted at the same place it stopped before.

Are here any other options to work around this bug, or am I stuck with waiting for Apple to fix it? Is there any way to go back to an earlier version of iBooks that doesn't have this problem?
 

madmaxmedia

macrumors 68030
Dec 17, 2003
2,923
32
Los Angeles, CA
I am guessing you have an older iPod that can't be upgraded to iOS 4, I think that's when the multitasking bar was added?

I think in Settings you can set a double-press of home button to bring up music player controls, that might work.

If nothing works, you may still be able to go back to old iBooks, if you haven't deleted it from your computer. When you update apps on your computer, I think it puts the outdated ones in the trash. So you can recover the old one, delete the new one from both iTunes and iPod, then re-install the old version.
 

photonwhiz

macrumors newbie
Original poster
Jan 19, 2012
3
0
Problem Solved by Time Machine!

Well, I have my books and music back again, thanks to Time Machine! I was able to locate an older version of iBooks (1.3.2) in my Time Machine backups and swapped that out for the new version (1.5) that was causing the problem. So I no longer have the "latest and greatest" (??), but at least I can now listen to music again while I read my iBooks. Thanks again for all your suggestions.
 

osmanvielma

macrumors newbie
Feb 7, 2013
1
0
Well, I have my books and music back again, thanks to Time Machine! I was able to locate an older version of iBooks (1.3.2) in my Time Machine backups and swapped that out for the new version that was causing the problem. So I no longer have the "latest and greatest" (??), but at least I can now listen to music again while I read my iBooks. Thanks again for all your suggestions.
Thanks to your thread...

I relived the same thing...

I worked out the same but with no 1.3.2 version but a 1.2.2 instead..

works flawlessly on really old 2G ipod

Cheers! :D :apple:
 

TacticalDesire

macrumors 68020
Mar 19, 2012
2,286
23
Michigan
The option to double click the home button for multitasking was added with iOS 4. But that wasn't included in the update the 2g touch and iPhone 3g got.
 

mrsmckoy11

macrumors newbie
Feb 20, 2013
1
0
ibooks download

hello is there anyway you can download the ibooks that works on 2nd gen ipod somewhere else?? please help just want my daughter to be able to read her ibooks!!