iBooks crashes with one particular book

Discussion in 'iPad' started by Aidoneus, Sep 20, 2011.

  1. Aidoneus macrumors 6502

    Joined:
    Aug 3, 2009
    #1
    I have been using iBooks for some time now, without problems. However, my most recent purchase does not seem to sit well with my iPad (1st generation).

    The book downloads to my library fine, but when I go to open it, it invariably crashes after approximately 20-30 seconds. I have redownloaded the book several times, reinstalled iBooks and restarted the device. All other books open fine on the iPad, and the book in question also opens fine on my iPhone 4.

    Any ideas an what is causing this?

    ETA: both devices are running iOS 5 Beta, but I don't think this is the problem, as it is localised to one specific book.
     
  2. EvenStranger macrumors member

    Joined:
    Oct 25, 2003
    #2
    If it's occurring on both devices with the same book, then the book file is most likely corrupted or damaged. Email iTunes Store support and let them know the specific title and maybe they can grant a credit for the book.
     
  3. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #3
    I've had this problem with, of all things, the user manual for my iPhone4. Makes no sense. I've uninstallled the manual several times and reinstalled it. Will work for a brief time and just quit. Touch to open the book, it "opens" and instantly puts me back to my home screen. I can't figure out what's going on.
     
  4. Aidoneus thread starter macrumors 6502

    Joined:
    Aug 3, 2009
    #4
    As I mentioned in the OP, the book works fine on my iPhone 4.
     
  5. stevep macrumors 6502a

    stevep

    Joined:
    Oct 13, 2004
    Location:
    UK
    #5
    I have no idea what the problem is, but would it be worth trying one of the 'remove drm' scripts that are widely available, and maybe converting the format? You'd obviously need to do some searching, but it might be worth a shot.
     
  6. taipan61 macrumors 6502

    Joined:
    May 18, 2011
    Location:
    corner starbucks
    #6
    was the book purchased from the apple book store? not really sure what could be the issue as it works on your phone (ios5) but not your first gen iPad (ios5)
    could it be something with the sync on the iPad?
     
  7. Aidoneus thread starter macrumors 6502

    Joined:
    Aug 3, 2009
    #7
    The book is from the Kindle store, and converted using Calibre. While it is possible that this is the problem, I have converted dozens of books this way before, without issue.

    As I said, the same file works perfectly on my iPhone, which suggests that the problem is with the iPad. I have tried resyncing the iPad several times (removing then re-adding the "Sync Books" field in iTunes), along with reinstalling iBooks.

    The only thing I have not tried so far is restoring the iPad.
     
  8. TheWheelMan macrumors 6502a

    TheWheelMan

    Joined:
    Mar 15, 2011
    #8
    The problem may be happening only on the iPad, but since it's just that one file, whatever is causing the crash is still specific to that file. Did you go all the way back to the beginning and try converting the file again?
     
  9. Aidoneus thread starter macrumors 6502

    Joined:
    Aug 3, 2009
    #9
    For those who care, I've found a way round the issue. Rather than converting straight from Amazon's .HTMLZ, first convert the book to .MOBI, and then re-import, and convert to .epub. Works for me!
     

Share This Page