ibtool failed with exit code 1

Discussion in 'iOS Programming' started by iphonejudy, Jan 30, 2009.

  1. iphonejudy macrumors 6502

    iphonejudy

    Joined:
    Sep 12, 2008
    #1
    Hi,


    I am having ppc.

    After i installed sdk 2.2.1,I run the xcode

    I got the below error,


    Building target “Test” of project “Test” with configuration “Debug”


    Checking Dependencies

    CompileXIB /Users/muralikrishnan/Desktop/Test/MainWindow.xib
    cd /Users/muralikrishnan/Desktop/Test
    setenv PATH "/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"
    /usr/bin/ibtool --errors --warnings --notices --output-format human-readable-text --compile /Users/muralikrishnan/Desktop/Test/build/Debug-iphonesimulator/Test.app/MainWindow.nib /Users/muralikrishnan/Desktop/Test/MainWindow.xib
    /* com.apple.ibtool.errors */
    Internal Error:
    Description: A method claimed to have failed but provided no error!
    /* com.apple.ibtool.warnings */
    Internal Warning:
    Description: ibtool encountered an error while loading the ibplugin from /Developer/Platforms/MacOSX.platform/Developer/Library/Interface Builder/Plug-ins/CocoaPlugin.ibplugin.
    Error: Error Domain=NSCocoaErrorDomain Code=3588 UserInfo=0x635010 "The bundle “Interface Builder Cocoa Plugin” could not be loaded." (dlopen(/Developer/Platforms/MacOSX.platform/Developer/Library/Interface Builder/Plug-ins/CocoaPlugin.ibplugin/Contents/MacOS/CocoaPlugin, 265): Symbol not found: _IBResizeActionIsOriginless
    Referenced from: /Developer/Platforms/MacOSX.platform/Developer/Library/Interface Builder/Plug-ins/CocoaPlugin.ibplugin/Contents/MacOS/CocoaPlugin
    Expected in: /Developer/usr/bin/../../Library/Frameworks//InterfaceBuilderKit.framework/Versions/A/InterfaceBuilderKit
    )


    Internal Warning:
    Description: ibtool encountered an error while loading the ibplugin from /Developer/Platforms/iPhoneSimulator.platform/Developer/Library/Interface Builder/Plug-ins/IBCocoaTouchPlugin.ibplugin.
    Error: Error Domain=NSCocoaErrorDomain Code=3588 UserInfo=0x638550 "The bundle “IBCocoaTouchPlugin” could not be loaded." (dlopen(/Developer/Platforms/iPhoneSimulator.platform/Developer/Library/Interface Builder/Plug-ins/IBCocoaTouchPlugin.ibplugin/Contents/MacOS/IBCocoaTouchPlugin, 265): Symbol not found: _IBLibraryClassesCategoryName
    Referenced from: /Developer/Platforms/iPhoneSimulator.platform/Developer/Library/Interface Builder/Plug-ins/IBCocoaTouchPlugin.ibplugin/Contents/MacOS/IBCocoaTouchPlugin
    Expected in: /Developer/usr/bin/../../Library/Frameworks//InterfaceBuilderKit.framework/Versions/A/InterfaceBuilderKit
    )


    Internal Warning:
    Description: ibtool encountered an error while loading the ibplugin from /Developer/Platforms/MacOSX.platform/Developer/Library/Interface Builder/Plug-ins/CarbonPlugin.ibplugin.
    Error: Error Domain=NSCocoaErrorDomain Code=3588 UserInfo=0x62b590 "The bundle “Interface Builder Carbon Plugin” could not be loaded." (dlopen(/Developer/Platforms/MacOSX.platform/Developer/Library/Interface Builder/Plug-ins/CarbonPlugin.ibplugin/Contents/MacOS/CarbonPlugin, 265): Symbol not found: _IBResizeActionIsOriginless
    Referenced from: /Developer/Platforms/MacOSX.platform/Developer/Library/Interface Builder/Plug-ins/CarbonPlugin.ibplugin/Contents/MacOS/CarbonPlugin
    Expected in: /Developer/usr/bin/../../Library/Frameworks//InterfaceBuilderKit.framework/Versions/A/InterfaceBuilderKit
    )

    command/usr/bin/ibtool failed with exit code 1

    Can anyone please tell me the solution

    Thanks
    judy
     
  2. eddietr macrumors 6502a

    Joined:
    Oct 29, 2006
    Location:
    Virginia
    #2
    What process did you follow to get the SDK to install on your PPC?
     
  3. iphonejudy thread starter macrumors 6502

    iphonejudy

    Joined:
    Sep 12, 2008
    #3
    I Drag the iPhone SDK package onto the Pacifist icon

    Select the top entry, “Contents of iPhone SDK”

    Click the “Install” button

    copy the platform folder and put in to the r main Developer directory.
     
  4. eddietr macrumors 6502a

    Joined:
    Oct 29, 2006
    Location:
    Virginia
    #4
    Well, it's possible 2.2.1 really doesn't work on PPC. (I assume you know that Apple doesn't officially support iPhone development on PPC)

    Maybe someone else here uses 2.2.1 on PPC and can help.

    Good luck.
     
  5. jnic macrumors 6502a

    Joined:
    Oct 24, 2008
    Location:
    Cambridge
    #5
    The SDK is not officially supported on PPC, please stop asking.
     
  6. iphonejudy thread starter macrumors 6502

    iphonejudy

    Joined:
    Sep 12, 2008
  7. jnic macrumors 6502a

    Joined:
    Oct 24, 2008
    Location:
    Cambridge
    #7
    You asked in this thread and were told no. Then you asked again and were told no. Then you started a new thread and were told no, twice. Then you started yet another thread (this one) saying you had problems with running under PPC and were again told (twice) that the SDK is not officially supported on PPC.

    This is the root of your problem. You either need to understand enough about computer architecture to hack the SDK to run under PPC, or you need to develop on an Intel based Mac.
     
  8. iphonejudy thread starter macrumors 6502

    iphonejudy

    Joined:
    Sep 12, 2008
    #8
    In the first thread ,I am asking about the system requirements.

    The second one i am asking about ibtool failed error.The guy replied me said ,that he doesnt know abt that and ask some one.

    So only i create a new thread and asked.Whats the mistake i done jnic?
     
  9. iphonejudy thread starter macrumors 6502

    iphonejudy

    Joined:
    Sep 12, 2008
    #9
    I think forums is used to discuss things only.

    if i disturb ,i unsuscribe from this group
     
  10. jnic macrumors 6502a

    Joined:
    Oct 24, 2008
    Location:
    Cambridge
    #10
    My point is, these aren't really distinct problems, they're all caused by trying to run the SDK under PPC architecture.

    Since this is a programming forum, the questions all end up coming across as "I'm using the SDK in a non-standard way and it's causing errors." This isn't really something most of us can help with, as evidenced by your lack of a solution in any of the threads listed above.
     
  11. iphonejudy thread starter macrumors 6502

    iphonejudy

    Joined:
    Sep 12, 2008
    #11

    Anyway thanks form ur reply jnic.u also helped me a lot and lot of time to solve my problems.thanks.
    bye
     
  12. EssentialParado macrumors 65816

    Joined:
    Feb 17, 2005
    #12
    For anyone (like I did) who comes across this thread because they're trying to run the iPhone SDK on PPC, the latest 3.1 update won't work. Some components are Intel only.

    What you need to do is download iPhone 2.2.1 for PPC and the follow the instructions.

    I spent all day yesterday scouring the web for the answer, and found this hidden away so wanted to post it here to help any other promising PowerPC iPhone developers. Good luck!
     

Share This Page