ical events layout issue in Lion

Discussion in 'Mac OS X Lion (10.7)' started by maclab, Jul 26, 2011.

  1. maclab, Jul 26, 2011
    Last edited: Sep 8, 2011

    maclab macrumors member

    maclab

    Joined:
    Aug 31, 2009
    #1
    Is anyone else suffering from this issue with ical in Lion? overlapping events is just a big mess in this latest version of ical, this issue did not exist in the previous version with snow leopard. How did these not get sorted already.

    THIS ISSUE DID NOT EXIST ON ical 4 - Snow Leopard edition !!!!!

    Lion ical !
    [​IMG]
    Ical in lion by maclabAU, on Flickr


    ipad ical

    [​IMG]
    Ipadical2 by maclabAU, on Flickr

    Very annoying !
     
  2. maclab thread starter macrumors member

    maclab

    Joined:
    Aug 31, 2009
  3. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #3
    stop overlapping them? i mean, make events (for example) a half-hour, if the next one is a half-hour later.

    i've been doing that forever, just to keep things neat...
     
  4. YMark macrumors 6502a

    YMark

    Joined:
    Nov 7, 2008
    Location:
    Arizona
    #4
    All the talented engineers at Apple, and they still can't put out a calendar application that doesn't look and perform like something written by high school kids.

    What a pathetic application. Address Book is the same POS.
     
  5. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #5
    first thing i i did in Lion: change the look of this (to get rid of that ridiculous brown paper top bar)... :D
     
  6. AnneStuarto238 macrumors member

    Joined:
    Mar 19, 2010
    #6
    Knowing some good alternative for both? :confused:
     
  7. YMark macrumors 6502a

    YMark

    Joined:
    Nov 7, 2008
    Location:
    Arizona
    #7
    Unfortunately I don't. If I come across one, I'll post.
     
  8. maclab thread starter macrumors member

    maclab

    Joined:
    Aug 31, 2009
    #8
    ummm...the appointment time is the appointment time, I can't move them around to make it look neater, I do see 2 clients at a time.

    ----------

    Also we did not have this issue on ical 4 in Snow Leopard !!!!!

    I have called Apple Care about this 3 times now to try and inform them, but Apple Care where useless! they just kept trying to guess what I was talking about and not replicating the issue, very frustrating, hence why I tried 3 times calling but have now given up on them.

    SORT IT OUT APPLE !!! WE NEED A CALENDAR

    ----------

    Busy cal is the only alternative at the moment, but they are dreaming that I will pay $50 for it in AU ....... and I shouldn't have to !
     
  9. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #9


    am talking about the END time; if appointments don't overlap, change the ends to not overlap, i.e. 4pm-415, or 2pm-230...

    make sense?
    works for me...
     
  10. dba415 macrumors 6502

    Joined:
    Jun 18, 2011
    #10
    Whatever happened to the "it just works" for Mac?

    Guess that ended with Lion did it?
     
  11. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #11
    i have my own issues with Lion, but...what are you talking about??
    if an end time overlaps a start time...it overlaps.
    a simple alternative is to stretch an appointment to the time of the next one.

    not complicated.
     
  12. maclab thread starter macrumors member

    maclab

    Joined:
    Aug 31, 2009
    #12
    Impossible in my case ..... I have a double booked schedule all the time for up to 10 hrs.....also we should not have too stuff around like this, I did not have an issue with ical 4 ..... but thank you for trying to help.
     
  13. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #13
    then, granted...apple should fix this. it DEF is better on the iPad...
     
  14. maclab thread starter macrumors member

    maclab

    Joined:
    Aug 31, 2009
    #14
    can anyone tell me if this has been fixed in 10.7.2 ?

    thx
     
  15. maclab thread starter macrumors member

    maclab

    Joined:
    Aug 31, 2009
  16. vandozza macrumors 6502a

    vandozza

    Joined:
    Jun 14, 2006
    Location:
    Australia
    #16
    Use Terminal.app to turn on the iCal Debug Menu -
    defaults write com.apple.iCal IncludeDebugMenu 1

    Then in iCal go to the debug menu > Top Sekret (sic) > Uncheck "use iPad style event layout."

    Quit iCal and restart. Did this help?
     
  17. maclab thread starter macrumors member

    maclab

    Joined:
    Aug 31, 2009
    #17
    Thank you so much ...... that did it !!! It had to be a fellow Aussie :)
     
  18. vandozza macrumors 6502a

    vandozza

    Joined:
    Jun 14, 2006
    Location:
    Australia
    #18
    Glad to help.

    You can now remove the debug menu if you don't wanna see that as well.

    (I've used an app MacPilot to show/hide these extra prefs in the past, then you can avoid the terminal.)

    Now... about this reward... :)
     
  19. jk10003 macrumors newbie

    Joined:
    Nov 12, 2011
    #19
    Change the look of iCal

    Sorry for dealing with an old post, but can you share how to change the new (dis-improved?) iCal look? Thanks.

    JK
     
  20. skunk macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
    #20
    I use BusyCal instead: it uses the old layout, and in addition gives you the option to view two weeks at a time.
     
  21. Djay1 macrumors member

    Joined:
    Nov 7, 2011
    Location:
    Middle Tennessee
    #21
    After a few iCal issues and the new "tacky" look, I sprang for BusyCal and the drop down calendar "Fantastical". The iCloud integration between the two as well as the integration of the two with iCalendar on my iPad 1 works seamlessly.

    Some extra bucks but very pleased with this combo.
     
  22. juliachidley macrumors newbie

    Joined:
    Nov 13, 2011
    #22
    This works!

    When I first came across this fix I didn't get it. I'm not computer savvy. I don't know PC language either. I finally got you have to type in the Terminal.app at the flashing curser the whole thing beginning with "defaults...1" just as it looks above spaces and all. Then the next part is in iCal where a new menu magically appeared "debug". Thought I'd give it another try. This time I took my time followed your instructions and it fixed my overlapping events! Thanks Vandozza!:D
     
  23. JamesEis macrumors newbie

    Joined:
    Mar 12, 2012
    Location:
    Cambridge
    #23
    Thanks - it worked!!

    Many thanks to vandozza for the original answer, and to juliachidley for putting it in words of one syllable for duffers like me! Can I add that I found I had to quit iCal and restart it after entering that occult incantation into Terminal.app. THEN I saw the 'debug' menu appear, and was able to follow vandozza's instructions. It worked! Magic!! :)
     
  24. nicktedesco macrumors newbie

    Joined:
    Apr 10, 2012
    #24
    Removing Debug Menu

    You can remove the debug menu by going back into terminal and typing

    defaults write com.apple.iCal IncludeDebugMenu 0

    The only thing changed from before is there is a 0 at the end of the command rather than a 1.
     
  25. dwimmer macrumors newbie

    Joined:
    Apr 13, 2012
    #25
    Thank you

    Thank you for the Debug menu tip. After switching from 7 day week view to 14 day view I noticed it did not switch back to 7 day week view. This was simply corrected by clicking month view and then back to week view. Just putting this tip out there.
     

Share This Page