iCal publish to WebDAV not working, username not being sent

Discussion in 'Mac Apps and Mac App Store' started by jakaj, Nov 19, 2007.

  1. jakaj macrumors member

    Joined:
    Oct 12, 2006
    #1
    Hi,

    I'm trying to publish a calendar to my server using WebDAV, but I get the following message:

    Authentication with server failed (http://username@server/Calendar.ics). Please check your login and password information.

    Checking the Apache access log, I can see:
    x.x.x.x - - [18/Nov/2007:16:18:47 +0100] "PUT /Calendar.ics HTTP/1.1" 401 547 "-" "DAVKit/2.0 (10.5.1; wrbt) iCal 3.0.1"

    This means that iCal didn't send a username (since the third column is "-") and got a 401 forbidden response.

    iCal should, to the best of my knowledge, either:
    a) send credentials immediately,
    b) connect without credentials, and only send them after it gets a 401.

    This is happening on OS X 10.5.1.

    I have not used iCal publishing before, so I'm not sure if Tiger would have worked, but connecting to the "share" using Camino, IE (on Windows) and mounting it on OS X work flawlessly, so I presume my server is OK.

    Also, publishing to iCal Exchange doesn't work either, so that's another reason to think that the problem is with iCal.

    Any ideas?

    Regards,
    Jaka
     
  2. ac90pilot macrumors newbie

    Joined:
    Jan 30, 2008
    #2
    same problem

    I set up my own webdav server using php and postgres great link on howto here
    http://parksmetal.com/rscds/docs/website/installation.php

    my webdav works great with evolution...When I look at the apache access logs I can see the 192.168.1.1 - admin [30/Jan/2008:23:28:21 -0800] "REPORT /caldav.php/resource1/home HTTP/1.1" 207 1462 "-" "Evolution/1.12.3

    with iCal I get
    192.168.1.1 - - [30/Jan/2008:22:57:59 -0800] "PUT /caldav.php/resource1/home.ics HTTP/1.1" 200 1467 "-" "DAVKit/2.0 (10.4.11; wrbt) iCal 2.0.5

    I tried adding the username and password to no avail i.e
    http://username:password@192.168.1.1/caldav.php/resource1/home

    This appears to be a real deficiency in iCal
     

Share This Page