iCal removes information from event titles!

Discussion in 'Mac Apps and Mac App Store' started by RedTomato, Feb 15, 2013.

  1. RedTomato macrumors 68040


    Mar 4, 2005
    .. London ..
    iCal on Mountain Lion.

    I only use iCal in Month view, and I only have 2 or three events per day. For the last 2 years I've been using iCal, each day's pigeonhole on the month-by-month view will show something like this:

    10am Client visit
    2-3pm Meet Surveyor
    5pm Pick up kids

    I'm happy with that, & it lets me check my availability and schedule across a whole month in one go.

    In Mountain Lion, iCal now uses Data Detectors (or something like that) to identify event times in the event title. It then *REMOVES* the time info and slots the event into the day-at-a-time or week-at-a-time view. So iCal grabs my carefully typed in event titles and munges them to look like this:

    Client visit
    Meet Surveyor
    Pick up kids

    WTF???? I typed in these event times, leave them there!!! *&£$ iCal! I have to retype in the time info in the event title every time it does this. I've looked on the internet and in other threads & I can't work out how to disable this behaviour.

    To test this yourself, in month view, double click on a day to create a new event, type in '9am visit doc' or whatever, and see the '9am' vanish.

    What's the one thing an scheduling manager shouldn't do? Remove scheduling information you typed in!

    Can anyone help?
  2. moderately macrumors 6502


    Sep 7, 2010
    I have "show event times" checked in the preferences>general pane. What I see in month view is something like this:

    Client visit 10am
    Meet Surveyor 2-3pm
    Pick up kids 5pm

    Would that work for you?
  3. deester3 macrumors newbie

    Mar 20, 2013
    iCal removes information from event titles!

    Just having the time display is not helpful.
    If the event is moved for any reason, the time is forever lost. The new 'time' of the event is wherever it is moved to, with no way the recover the original time. I agree with the author of this thread. The title is text that I have entered for a reason and it belongs to me. The application has no business deleting text (even it is very proud of itself for being able to interpret what is typed.)
  4. jezabit macrumors newbie

    Apr 15, 2008
    If you type the time in twice it will delete one and leave the other

    Agreed! very annoying ....Hope they fix this
  5. Point macrumors newbie

    Jul 1, 2013
    This should at least be a preference setting

    For users who like the day or week views, it might be convenient to have the time parsed and removed, but not for us month-view users who rely on having it in the title (where it's not subject to accidental rescheduling). For us, it's very annoying.

    Even MS Word has preferences to turn off annoying "features" like this. C'mon apple, you can do better!
  6. ItWasNotMe macrumors 6502

    Dec 1, 2012
    Apple don't like preferences, Tim Cook said "the customer pays us to make certain choices on their behalf."
  7. ApfelKuchen macrumors 68030

    Aug 28, 2012
    Between the coasts
    I happen to like the current behavior, but I also see how you'd find it inconvenient and frustrating. Your need seems to deserve a Preference of some sort. Have you shared your thoughts with Apple at http://www.apple.com/feedback/macosx.html ?

    I'd argue in favor of keeping the current behavior as the default. Like auto-correct in iOS (which can save significant amounts of keying), once one adapts, it can produce meaningful savings in time and effort. Yeah, Apple has a way of "knowing better," but if new ways of doing things aren't shoved under our noses, we have a tendency to stick to the old and slow. ("Improvements" that are just change for the sake of change are a different matter - I don't feel this is in that category.)
  8. RedTomato thread starter macrumors 68040


    Mar 4, 2005
    .. London ..
    Resurrecting this thread to note that this behaviour still exists in OSX Mavericks and still cannot be changed.

    Of course, this removal of scheduling information is but a small piffle in the general cataclysmic train wreck that is iCal on iOS 7.
  9. jalfano macrumors newbie

    Feb 24, 2014
    Automatically removing time from title in ical events

    This drives me completely crazy too. I much prefer putting numbers in my events name in two important situations: 1. I work shifts, some are 7-3, 9-5, 2-10, 4-12, etc. I want to see the kind of shift in the title, but Apple (trying to become Microsoft) would rather think for us. 2. Airplane flights. Don't even get me started on the disaster that is time zone "support". I gave up trying to put flight times in the event. Apple needs to offer an option in which all times are local. I know what time zone I'm in. It just becomes confusing to look at events scheduled for a different time zone and have to sort out in your head when they're actually occurring. Apple thinks we don't need to know until we arrive in that time zone. There are so many things wrong with that approach.
    If anyone finds a fix for the data detectors pulling the numbers out of the event title, I would very grateful and hate apple less for their arrogance. They make better products than most, but they don't make great products. They rest on their laurels and insult the sophisticated user. The problem is that society has become much more sophisticated in it's use of technology and apple won't catch up.
  10. SJLo macrumors newbie

    Jan 20, 2015
    Ical / Calendar Event titles with time information

    I was very frustrated with the elimination of time in the calendar titles. I think I may have found a solution. When you are finished typing the event title, click on the block background / underneath the scheduling suggestion (the block where you type in location, invitees, etc) and click on "all day". This seems to work for me - keeping the time in the title. My system was recently upgraded, so I hope it works for everyone.
  11. katemc macrumors newbie

    Jan 21, 2015
    I am in the same boat and finally at my wits end. Please, everyone on this thread use the above link and make a request to Apple to please give us the option. My only option right now is to write something ridiculous like "10amblahblah". It's awful.
    I also don't even seem to have the option in the general settings to show even time. That would work for me too.
  12. Fialach, Feb 18, 2015
    Last edited: Feb 18, 2015

    Fialach macrumors newbie

    Feb 18, 2015
    iCal, stop deleting my times from event title!

    I have exactly the same problem. WHY would Apple do this? I have lost so much info this way.

    I don't have many events per week, and have always preferred to check "all-day" so that I know which days I have an event.

    I put the time info into my event title so that I could see all my info for a week at once. Also, I have always used the event title to put all my info for travel; iCal is now DELETING the times and force-changing my entry away from all-day. Now, many of my events look like this: "Meet D for lunch, " because iCal has deleted the time I put in. This is especially horrible when I have entered a lot of flight connections and time info. No, Apple, you don't know better than I do what I want in my event title.

    WHY would they ever delete a time that I deliberately entered into the title field? Is there any work-around? This is driving me crazy.

  13. markalex49 macrumors newbie

    May 7, 2015
    iCal Time workaround

    I just use semicolon instead of colon. Time shows as 10;30
  14. dirk123 macrumors newbie

    Aug 31, 2015
    Since data detectors are handled by Mail & not iCal itself you may turn this feature off with the following command entered in Terminal:

    defaults write com.apple.mail DisableDataDetectors YES

    To revert this behaviour:
    defaults write com.apple.mail DisableDataDetectors NO

    *Please note that any time detection features of Mail are turned of as well.
  15. jess89989 macrumors newbie

    Sep 9, 2015

    There is no 'show event times' option in the preferences section anymore. this option has been removed and there is still no way to preserve event times in calendar view.
  16. jess89989 macrumors newbie

    Sep 9, 2015
    what does this mean? i enter what, where?
  17. dirk123, Sep 9, 2015
    Last edited: Sep 9, 2015

    dirk123 macrumors newbie

    Aug 31, 2015
    Yes :)

    More detailed*
    A. open up Terminal.app, located in /Applications/Utilities/
    B. paste the following into the open Terminal window:
    defaults write com.apple.mail DisableDataDetectors YES
    C. from now on your event time entered in calendar are preserved

    *Confirmed (by me) to work on OSX Lion (10.7.4), Mountain Lion, Mavericks and latest Yosemite

    To revert this behaviour just open Terminal.app again and enter:
    defaults write com.apple.mail DisableDataDetectors NO

    Short explanation: Data Detectors are handled by Mail, not by iCal itself.
    Therefore this behaviour has to be set for Mail.app. Searching elsewhere yields no results.

    Add. info:
    OSX is mostly controlled by XML. Taking over control of the system is nowadays often done via changing simple XML content. The command line (in Terminal) is the easiest way to alter this info by simply entering a new command string.

    The Terminal command for this is always "defaults write", followed by the name of the plist and the string (YES or NO in this case). You could literally spend a lifetime searching a normal .plist for this when using only spotligh - and probably you would not find it ... but I tell you no secret that the above setting will most likely be stored in:
    This .plist is not residing in your user nor root library preference folders but inside a container.

    Since this specific string is handled by the user itself, no "superuser "or other questionable security info is needed.
  18. moderately macrumors 6502


    Sep 7, 2010
    Typing "10:30a" will remain in the title. The event can be moved to any time and the 10:30a remains. And you save a keystroke!

    I guess I don't understand the problem.

Share This Page