iCal Time Display Problems

Discussion in 'Mac Apps and Mac App Store' started by BigPrince, Jun 14, 2007.

  1. BigPrince macrumors 68020

    Joined:
    Dec 27, 2006
    #1
    In iCal none of my times display correctly for the day. it either says Noon, midnight, Sat AM, Sat PM instead of numbers for the correct time.

    I did use monolingual to remove some langauge stuff, but thats all I did that I can recall that would of modified these settings. I am willing to reinstall if needed, but was wondering if there was another way.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Where exactly are you talking about? Maybe post a screenshot. :)
     
  3. BigPrince thread starter macrumors 68020

    Joined:
    Dec 27, 2006
    #3
    OK, here it is, thank you for your reply.
     

    Attached Files:

  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Weird. Okay, if you create a new user account do you get the same problem there? Also, did you let Monolingual touch any of the architecture info? :)
     
  5. BigPrince thread starter macrumors 68020

    Joined:
    Dec 27, 2006
    #5
    i did, did that screw it up?


    EDIT: I can't log out cause im syncing over 13000 photos to my iPod, sorry.

    Do you recommend a complete reinstall and then don't let monolingual touch it?

    If I do, how to do a "lite" install of just the things I need.

    Possibly an archive install will correct this?
     
  6. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    If you touched the architectures then yeah, an Archive & Install should help you out. :)
     
  7. BigPrince thread starter macrumors 68020

    Joined:
    Dec 27, 2006
  8. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  9. demi69 macrumors newbie

    Joined:
    Apr 21, 2009
    #9
    I have the same problem

    Hi, I have encountered the same problem, but I did not mess with ical's settings. The only thing I could think of is that I just subscribed to mobileme. Could that have caused the problem. If so, how do I fix it?

    Thanks so much!

    dk
     
  10. pakman macrumors newbie

    Joined:
    Jul 18, 2009
    #10
    I've just hit the same problem. I have just added (for the first time ever) a couple of appointments directly from Mail.

    It is not just the time of day down the side of the display that doesn't show up, I can't see or edit the time of events either (see screenshot). The time is definitely stored, because when I sync with my mobile phone (a Sony Ericsson) events that are newly transferred to the phone have the correct time. It seems that just the iCal user interface doesn't have any awareness of time any longer.

    If I log in as another user, iCal handles the time correctly.

    I have tried moving ~/Library/Preferences/com.apple.iCal.plist and re-starting iCal, but that didn't help

    Any ideas anyone? I am running 10.5.6 on a MacBook Pro.
     

    Attached Files:

  11. southerndoc macrumors 65816

    southerndoc

    Joined:
    May 15, 2006
    Location:
    USA
  12. pakman macrumors newbie

    Joined:
    Jul 18, 2009
    #12
    Yes I have, although the limited number of reports of this problem indicates that it is very uncommon, so I am not optimistic that reports about it to Apple will make it through triage. I am also reluctant to go down the Apple support route, because they would probably try to get me to upgrade to 10.5.7 which could be a disaster.

    I'll probably end up switching from iCal to something else like Sunbird because of this, as long as I can find a way of syncing my calendars to my mobile phone.
     
  13. pakman macrumors newbie

    Joined:
    Jul 18, 2009
    #13
    iCal Time Display Problems - Solved!

    Eventually found in System Preferences -> International -> Formats that my region was set to "Custom". I have no idea how this happened - I certainly never set this directly through system preferences.

    I selected "United Kingdom" as my region, and the times showed up in iCal once again.
     

Share This Page