Ichat after 10.5.1 update!!

Discussion in 'macOS' started by King t., Nov 17, 2007.

  1. King t. macrumors regular

    Joined:
    Oct 31, 2007
    #1
    after updating to 10.5.1, I've been having problems with Ichat. AUdio chat, video chat and screen sharing no longer work!!

    Great UPDATE!!! :mad:

    1000 thanks to :apple:
     
  2. G4R2 macrumors 6502a

    Joined:
    Nov 29, 2006
    #2
    My first impression with an issue like this is that it might be a firewall issue. Apple fixed some firewall issues with 10.5.1. It might be possible that prior to the update iChat was meant to be blocked in the firewall but the firewall wasn't working properly so it appeared applications that were meant to be blocked were still working. With the update those applications might now be blocked.

    I hope you find an easy solution to your problem.
     
  3. Sandock macrumors member

    Joined:
    Aug 10, 2006
    Location:
    Calgary, Canada
    #3
    Same issue here. iChat used to work fine for me since I upgraded to Leopard, but update 10.5.1 seems to have done something to it that I can't get video chat to work anymore.
     
  4. King t. thread starter macrumors regular

    Joined:
    Oct 31, 2007
    #4
    is there a way to reverse the update, but not with a new install.
     
  5. petvas macrumors 601

    petvas

    Joined:
    Jul 20, 2006
    Location:
    Mannheim, Germany
    #5
    iChat works fine for me. Remember if you have a router with firewall enabled, you will have to enable port 5678 (tcp) and 16492 (udp)
     
  6. King t. thread starter macrumors regular

    Joined:
    Oct 31, 2007
    #6
    but befor the update everything was working fine, why should I now have to enable the ports??

    it was working befor the update just fine, and now the only thing that works under ichat is chatting. no more video, audio & screen sharing :(
     
  7. G4R2 macrumors 6502a

    Joined:
    Nov 29, 2006
    #7
    It's possible that the ports were also set to being blocked before in your Leopard setup but the firewall was not working correctly. With the update several firewall issues were resolved so now it may be properly blocking those ports.
     
  8. Gnufist macrumors newbie

    Joined:
    Nov 17, 2007
    #9
    Found a solution

    I had the same problem, after updating to 10.5.1 I no longer could get iChat to work. My firewall setting in System Preferences/Security/Firewall was set to "Allow only essential services".
    In order to get iChat to work again I had to change it to "Allow all incoming connections"
    I tried to add iChat to the list of specific services and applications to get it to work while having the "Allow only essential services" option clicked but no luck.
    I guess Apple have a new bug here, so for now if you want iChat to work disable the Apple "Firewall"
     
  9. petvas macrumors 601

    petvas

    Joined:
    Jul 20, 2006
    Location:
    Mannheim, Germany
    #10
    Read this: http://docs.info.apple.com/article.html?artnum=306938

    You should just set the firewall to the third option Set access for specific services and applications
    This will work for iChat. All Apple apps in Leopard are signed, thus trusted. You don't need to add iChat to the list, unless you specifically want to block it.
     
  10. King t. thread starter macrumors regular

    Joined:
    Oct 31, 2007
    #11
    has anybody found a solution?? :(

    cause I still am not able to use Ichat the way that I used too. prior to the update.
     
  11. Big-TDI-Guy macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #12
    King - first, I just love your lashing out in that opening post. Top notch stuff. :D

    Not to kick any more sand into your face.

    If you have a router - especially one of the D-Link flavor - those seem to have given me hell with iChat. Regardless - just cycle power on your router - they do tend to lock up and drop ports.

    If the receiving party has one - have them do the same.

    Also - if "Stealth" browsing is turned on, especially on both Macs - for some reason, it can completely refuse to connect. (it says that the other individual failed to respond to your request)

    The other firewall settings have already been covered. So I dunno.

    Glad I didn't install 10.5.1 yet, as ichat / screen saving is just about the only reason I KEPT Leopard.
     
  12. Scalfani macrumors member

    Joined:
    Aug 2, 2007
    #13
    so weird... after I updated to 10.5.1, my video chat and screen sharing now work. Before it didn't.

    ?
     
  13. kkat69 macrumors 68020

    kkat69

    Joined:
    Aug 30, 2007
    Location:
    Atlanta, Ga
    #14
    That's wierd, mine worked before AND after the update with no issues what so ever.

    Yes great update Apple. Thanks for fixing some of those issues. From this user it's much appreciated

    See above. Thanks again.
     

Share This Page