iChat = epic fail application in OS X

Discussion in 'Mac Apps and Mac App Store' started by kidwithdimples, Jul 13, 2008.

  1. kidwithdimples macrumors 6502a

    Jun 17, 2007
    I stayed up until 5 am last night trying to get this !@#$% to work. I'm really pissed off.

    Me and my friend have Screen Sharing enabled and we both are on high speed broadband. It worked with another friend and then when I try with a friend who just got a new MBP... it doesn't work at all.

    I get that "Screen sharing with ...." in big letters and thats it. There is an icon that blinks red at the top.

    We can both hear each other but he can't see mine. He screen shared with me and I was able to see his.

    What port do I need to forward, if any?

  2. GGJstudios macrumors Westmere


    May 16, 2008
  3. Eidorian macrumors Penryn


    Mar 23, 2005
    Most of my Screen Sharing issues involve mindnumbing NAT transitions with the network setups some of my friends have.
  4. kkat69 macrumors 68020


    Aug 30, 2007
    Atlanta, Ga
    Doing this is what helped me from staying up that long to get it fixed with my parents.

    Googled and searched those 2 places had the answers I needed. Now the screensharing is a champ.

    NAT as the above person said is the biggest issue, also changing both quicktime and the settings in ichat for streaming helped as well.

    iChat <> epic fail.
  5. kidwithdimples thread starter macrumors 6502a

    Jun 17, 2007
    How do I fix this NAT problem? =\

    Where is this in my netgear configuration page?
  6. GSMiller macrumors 68000


    Dec 2, 2006
    If it's working for you and not for your friend they may have Internet Sharing enabled. Under system preferences click the Sharing icon and make sure the box beside "Internet Sharing" isn't checked.
  7. kidwithdimples thread starter macrumors 6502a

    Jun 17, 2007
    We both only have Screen Sharing and File Sharing on. When I send him invitiaton to view his screen... it works. When I try to share my screen with him it doesn't work.

    However; Screen Sharing (application found in core services) works but that is too laggy. iChat is much better
  8. MacGeek7 macrumors 6502a


    Aug 25, 2007
    Really? It's been the opposite for me, with Screen Sharing being faster than iChat, but you have to be on the same network for Screen Sharing to work anyway.
  9. kidwithdimples thread starter macrumors 6502a

    Jun 17, 2007
    Not really ;) if you forward ports 5900 and 3280 then you can view your friend's desktop without being in local network. That's what I just did.
  10. Fulgham macrumors regular

    Feb 13, 2008
    Edmonton, Alberta
    OK... I tried searching... but I must be blind.... I am having the same issue... Someone kind enough to point me towards a specific search term or link to the other thread / support article with the help?

    2 MacBook Pro's running 10.5.4 on high speed connections.

    Screen sharing works one way... When launched the other way (which I need cause I'm kinda handling the tech support) I get access to the other users mic (i can hear them) ... but thats as far as it gets.

    Their system has screen sharing enabled in the sys prefs.
  11. Frisco macrumors 68020

    Sep 24, 2002
    Essentially, 3 steps:

    1: Go to the Quicktime streaming setting, sys prefs/quicktime/streaming/streaming speed, set to 1.5mbps(i.e., dont use automatic)

    2. In ichats prefs click on video and change bandwidth limit to NONE.

    3. Restart iChat
  12. Fulgham macrumors regular

    Feb 13, 2008
    Edmonton, Alberta
    Thanks... Gotta wait for her to get back to test.
  13. Wee Beastie macrumors regular

    Aug 20, 2007
    In the snow with Rosebud

    Reviving a month old thread just to say thanks to Frisco. I was at a loss as to why screen sharing wasn't working on my local network. Thanks for the quick and easy fix. I just wish that I had have searched here first instead of wasting time looking at other sites. I usually come to macrumors first for all mac troubleshooting issues. This time I didn't for some reason. Once I did, my problem was solved within five minutes. So rock on macrumors...


Share This Page