ichat/itunes/safari won't launch, any ideas?

Discussion in 'Mac Basics and Help' started by grlinirland, Aug 11, 2009.

  1. grlinirland macrumors newbie

    Joined:
    Aug 11, 2009
    #1
    Hey there!

    I've had my macbook 1,1 running OS X 10.4.11 for going on 4 years now. Its been great, nothings really gone wrong.

    I recently got an external hard drive and that worked great.

    but about a week ago when i turned it on it wouldn't log in, kept rebooting in safe mode, said my password was incorrect, for about a day, tried lots of stuff, nothing seemed to help, the next day it was more or less fine (i was someplace without internet) the airport symbol was gone from the top but next time i connected it came back when i changed the internet settings.

    its been running fine, firefox, word, iphoto all work with no problem. However, ichat, itunes and safari won't start.

    I looked up some similar stuff and have tried some of the font moving stuff etc but they still won't open. I got rid of itunes and re-downloaded it and nothing.

    i think some updates might have downloaded? Also i think some stuff was downloading and the computer froze so i used force quit during the download. (for itunes only)


    I looked at the logs and each time i try to start one of them i this comes up :

    Aug 11 14:55:47 annie-strouds-computer crashdump[491]: Safari crashed
    Aug 11 14:55:47 annie-strouds-computer crashdump[491]: crash report written to: /Users/annie/Library/Logs/CrashReporter/Safari.crash.log
    Aug 11 14:55:54 annie-strouds-computer MxBt NotificationExec: [492]: kCGErrorRangeCheck : Window Server communications from outside of session allowed for root and console user only
    INIT_Processeses(), could not establish the default connection to the WindowServer.launchd[399]: com.seagate.notificationexec.plist: exited abnormally: Abort trap
    launchd[399]: com.seagate.notificationexec.plist: respawning too quickly! throttling
    launchd[399]: com.seagate.notificationexec.plist: 1 more failure without living at least 60 seconds will cause job removal
    launchd[399]: com.seagate.notificationexec.plist: will restart in 10 seconds
    Aug 11 14:56:04 annie-strouds-computer MxBt NotificationExec: [493]: kCGErrorRangeCheck : Window Server communications from outside of session allowed for root and console user only
    INIT_Processeses(), could not establish the default connection to the WindowServer.launchd[399]: com.seagate.notificationexec.plist: exited abnormally: Abort trap
    launchd[399]: com.seagate.notificationexec.plist: respawning too quickly! throttling
    launchd[399]: com.seagate.notificationexec.plist: too many failures in succession
    2009-08-11 14:58:05.651 SpeechFeedbackWindow[468] _NSShapePlainWindow: error setting window shape (1001)
    Debugger() was called!
    dyld: Symbol not found: __ZNK3KJS6JSCell18getTruncatedUInt32ERj
    Referenced from: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
    Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore

    Aug 11 15:01:06 annie-strouds-computer crashdump[511]: Safari crashed
    Aug 11 15:01:06 annie-strouds-computer crashdump[511]: crash report written to: /Users/annie/Library/Logs/CrashReporter/Safari.crash.log
    Debugger() was called!
    Debugger() was called!
    Debugger() was called!
    dyld: Symbol not found: __ZNK3KJS6JSCell18getTruncatedUInt32ERj
    Referenced from: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
    Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore

    Aug 11 15:17:57 annie-strouds-computer crashdump[516]: iTunes crashed
    Aug 11 15:17:57 annie-strouds-computer crashdump[516]: crash report written to: /Users/annie/Library/Logs/CrashReporter/iTunes.crash.log
    dyld: Symbol not found: __ZNK3KJS6JSCell18getTruncatedUInt32ERj
    Referenced from: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
    Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore

    Aug 11 15:18:59 annie-strouds-computer crashdump[520]: iChat crashed
    Aug 11 15:18:59 annie-strouds-computer crashdump[520]: crash report written to: /Users/annie/Library/Logs/CrashReporter/iChat.crash.log


    *also, on the crashreporter all of them say
    Symbol not found: __ZNK3KJS6JSCell18getTruncatedUInt32ERj
    Referenced from: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
    Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore

    I don't know if that helps/is important?
    If anyone has any idea of what i could do to fix this it'd be great!! Thanks a bunch!
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    I'm assuming from those logs that the external hard drive you got is a Seagate (or possibly a Maxtor Onetouch), and that it came with some kind of software (something, I'm guessing, that uses a button on the drive, maybe). Assuming this is the case, the driver for that seems to be acting up. This may or may not have anything to do with your other problem, but unless you really like whatever feature it's supplying, I'd recommend removing it (the drive should still work fine, it just won't be able to use whatever added feature the Seagate software is trying to give you).

    Second, it appears that webkit (the core of Safari) is crashing; not sure if iChat and iTunes use it, but probably, and if so that would explain why they don't work and other apps do (how about Mail?).

    As a first-line test, you should probably try creating a new user through the Accounts preference pane, then log in as that user and see if Safari et al work. If so, that narrows the issue down considerably; if not, then it's something systemwide.

    In the event it is systemwide, what I would recommend trying short of a full OS reinstall (or rather archive and install, which will save all your files and settings) is to redownload Safari 4 and install it (I think it will allow you to install again). That will, hopefully, fix whatever got chewed up in Webkit. You could also try downloading the 10.4.11 "combo" update and installing that.

    Alternately, for the reinstall (which will almost certainly fix it--again assuming it's a system issue rather than something specific to your user), make sure you have a backup of anything important, then start up from the disc that came with the computer and follow the instructions, making sure to go to the Options button and select "Archive and Install" with the "Preserve users and network settings" box checked. Then run Software Update and let it install updates until it says there's nothing left to update and hopefully you'll be good to go.
     
  3. grlinirland thread starter macrumors newbie

    Joined:
    Aug 11, 2009
    #3
    I tried re-downloading safari and got rid of the seagate software but ichat/itunes/etc still won't open. they don't work on a new user account either.

    When i re-downloaded safari i wasn't able to install it because installer keeps "closing unexpectedly"

    Installer still works for other programs- i just installed songbird for the meantime till i can get itunes working again:/

    It seems to work for some other stuff like the facebook exporter for iphoto buuut when i open iphoto the exporter doesn't show up...not sure if thats related.

    I can't find my install disk either:/ might be in my apt. at school so I guess I'll have to wait till the end of the month before i can archive and install.

    Thanks for the info!!
     

Share This Page