iChat screen sharing

Discussion in 'Mac Apps and Mac App Store' started by nabisco, Mar 24, 2011.

  1. nabisco macrumors newbie

    Joined:
    Sep 12, 2008
    #1
    Hello,
    wonder if any of you might be able to help. I'm trying to setup screen sharing with my mother's new macbook pro in Spain and it's very temperamental (connects about 1 in 20 attempts). I've managed to connect easily enough when she was in the UK, so I think it must be her router in Spain. The thing is though that one of the times I managed to get through to her screen sharing I placed her computer in the DMZ on the router so there shouldn't be any firewall/port forwarding issues afaik. Hers is a Belkin f7d2301
     
  2. jdechko macrumors 68040

    Joined:
    Jul 1, 2004
    #2
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    Have her open iChat, login, and from the Video menu, select Connection Doctor, and then Capabilities from the dropdown. Are there green checkmarks next to all/some? Even if you don't think its a firewall issue, you should consider going through this support article for ports relevant to iChat functionality. Also, if you have a MobileMe account, you can try using Back To My Mac.
     
  4. nabisco thread starter macrumors newbie

    Joined:
    Sep 12, 2008
    #4
    Yep she's got green lights on everything apart from host multiperson video. She has a 4Mb connection which should be adequate.

    I tried Teamviewer and it did manage to connect but it was a frustrating experience to be honest.

    If I can get it to connect one of these times then I'll try to set up port forwarding on the router. If anyone else has suggestions for Belkins with screen sharing then let me know
     
  5. nabisco thread starter macrumors newbie

    Joined:
    Sep 12, 2008
    #5
    ok, I've since discovered that her modem (wired) also has a built in 1-port router, which seems to have been causing the problem. I tried the following but still couldn't get iChat to work:

    1. took the WAN IP address and MAC from her Belkin wireless router's setup homepage and copied that into the static IP setup screen of her Zyxel p-660r-d1 modem/wired router.
    2. entered the WAN IP address of the Belkin into the NAT screen for the zyxel p-660r-d1 for all ports.
    3. disabled the firewall on the Belkin.

    I don't know much about networking but I would have thought that would be everything open now? Instead the Connection Doctor shows no screen sharing or multiperson video. In actuality it can't even do single person audio, so clearly I've made a mistake somewhere.
     

Share This Page