iChat windows always staying on top - why?

Discussion in 'macOS' started by ero87, Nov 1, 2007.

  1. ero87 macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
    #1
    Hey,

    So in Leopard, my iChat conversations stay above my Safari, Word, etc. apps even when I click on the other application. In Tiger, the iChat would've receded to the back, but they seem to be permanently-hovering windows.

    Anyone know a fix? Thanks! :)
     
  2. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #2
    I'm still on Tiger, and I use Chax to get tabbed browsing. There is the option in Chax to have iChat windows always be on top. Perhaps you used something like this also with Leopard?
     
  3. janitorC7 macrumors 6502a

    janitorC7

    Joined:
    Feb 10, 2006
    Location:
    North Hollywood, CA
    #3
    if i was not on my iphone i would give you the ban hampster, please do not bump

    And i believe that a floating ichat is an option in leopard, check ichat prefs
     
  4. Eluzion macrumors 6502

    Joined:
    Aug 7, 2007
    #4
    You would think, but Apple doesn't make things an option.

    I'm also having the same issue except it's only with certain people I talk to. The windows just stay above above everything. Doesn't happen to everyone, just a select few people I talk to (which actually never did it for them before).

    *bump* ;)
     
  5. ero87 thread starter macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
    #5
    Yeah I think that's right! It's only with some people, so strange. Well, Chax should come around soon and fix it...

    and janitorC7, i've been around here for a while and i've never known that we can't bump. I just bumped this thread, and if i hadn't I wouldn't know that other people are experiencing the same issue. Let's all be friendly, yeah? :)
     
  6. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #6
    From the MR Rules:
    Minor Problems
    Certainly doesn't justify a ban hamster :p
    But, I know the mods appreciate keeping it to a minimum. As long as it's not abused, you're probably fine. Just FYI.
     
  7. Eluzion macrumors 6502

    Joined:
    Aug 7, 2007
    #7
    So no one else is experiencing this issue? It's very annoying and I'm guessing a bug since there is no option for it and I can't figure out if there's a hot key. Everyone is probably using Adium. ;P

    Just had it happen to another person on my buddy list. I closed the chat window and reopened it, problem gone. What the hell, it's so random. Sometimes it won't go away, other times it will.
     
  8. cheezebob macrumors member

    Joined:
    Jun 27, 2007
    #8
    I have this problem too. It seems to happen when someone starts a chat with me. I seem to be able to get it to stop happening by closing windows and unchecking and rechecking the some options..i really have no idea if that helps, it does seem pretty random.

    I just made a separate space for iChat.
     
  9. freudianslipper macrumors newbie

    Joined:
    Nov 3, 2007
    #9
    Here's how I fixed this issue

    I've fixed this issue by disabling the autoaccept apple script in ichat's preferences.

    Preferences > Alerts > Event: Text Invitation

    Uncheck Run Applescript if it's checked. It's too bad though because I love auto accept.
     
  10. neven macrumors 6502a

    Joined:
    Oct 10, 2006
    Location:
    Portland, OR
    #10
    Just wanted to confirm that this solution worked for me too. Auto-accept on, windows stay on top. Auto-accept off, windows act normal.

    I can't find the auto-accept applescript itself (my guess is it's not stored as a file) so I don't know why this is happening, but I've submitted a bug report to Apple.

    P.S. This will only happen if the other person starts the chat (and the applescript gets executed). If you start the chat, the window will act as expected.
     

Share This Page