iCloud back up info iOS 10.3

flyingspur

macrumors regular
Original poster
Aug 5, 2013
128
105
Dallas TX
Noticed under: Settings, Owner/Apple ID, select iPhone, right below Find my iPhone and iCloud Backup.

In the gray area above Device Info, mine displays "Last iCloud Backup: Never"

I go into iCloud, iCloud Backup and it displays, "Last Backup: Yesterday at 2:44 PM"

Anybody else see this for your iPhone, iPad etc.?
 
Last edited:

zorinlynx

macrumors 603
May 31, 2007
6,103
8,804
Florida, USA
Yup, same here. Looks like a bug.

Also in 10.3.1.

Anyone on 10.3.2 beta want to chime in and let us know if this was fixed?

EDIT: Another data point: Same issue on iPad (2017) with 10.3.1. So this isn't a fluke; seems reproducible every time.
 

Mefisto

macrumors 65816
Mar 9, 2015
1,310
1,592
Finland
Same here. On the device's page it says "Never", and when I go into iCloud Backup on the same page, it says the time of the last backup.

Unrelated, the page for my Apple TV insists that the device is till on 10.1.1, which is not the case.

Minor problems, but hopefully there's a fix coming.
 

venomgt95

macrumors 6502
May 8, 2014
457
121
Michigan
IMG_2297.jpg Ever since I updated to 10.3, in the new settings, when I look at my device info, it says my phone was never backed up, even though it gets backed up every night. It displays my 4S's information just fine but not my main phone.

Bug?
 

spikeymike

macrumors newbie
Jul 6, 2010
28
13
I had the same issue on my 7 after updating. iPad was fine.

What worked for me was signing out of iCloud and signing back in. After doing this it showed the last backup time.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.