iPhone iCloud Backup Fails

Discussion in 'Jailbreaks and iOS Hacks' started by ldstern, Feb 11, 2013.

  1. ldstern macrumors newbie

    Joined:
    Sep 6, 2006
    #1
    Since jailbreak on 6.1 IOS, I have been able to backup to iCloud on my iPhone 5. Backup fails after a few seconds. I tried turning iCloud backup option off and then on again. It made no difference. I have plenty of available storage space.

    Anyone else with this issue?
     
  2. lissa5168 macrumors newbie

    Joined:
    Nov 28, 2011
    Location:
    East TN
    #2
    I had the issue. Do you by any chance have PkgBackup installed? For some reason, it doesn't play nice with iCloud stuff. I had to restore, re-jailbreak, and reinstall everything except PkgBackup to get it working again.
     
  3. ldstern thread starter macrumors newbie

    Joined:
    Sep 6, 2006
    #3
    I do have PKGBackup installed. I removed it but still can't backup. I guess I'll try to restore and rejailbreak. Hate to have to do this. Thanks for your help.
     
  4. ldstern thread starter macrumors newbie

    Joined:
    Sep 6, 2006
    #4
    I think I found a,solution. I uninstalled PKGBU and then reinstalled. When opening app, I selected the option to allow access to iCloud photos. I then was able to perform a successful iCloud backup. When I originally installed the app, I chose the option to deny access to iCloud photos..
     
  5. appleculton macrumors newbie

    Joined:
    Feb 11, 2013
    #5
    May be simpler?

    @ldstern

    So I was having the same problem today with my iPhone 5 on 6.1

    Before trying to uninstall PKGBackup and reinstall it, I thought of something else. There is a way to give the app permission to access your photos other than just at installation. For future reference, you can go right into settings/privacy/photos and restore privileges to PKGBackup.

    I tried that and then just did one final backup with PKGBackup and then tried to do an iCloud backup and it worked :) YAY!:apple:
     
  6. lissa5168 macrumors newbie

    Joined:
    Nov 28, 2011
    Location:
    East TN
    #6
    Thanks! I will try it again then. I miss PkgBackup.
     
  7. ldstern thread starter macrumors newbie

    Joined:
    Sep 6, 2006
    #7
    I have iFile but can't locate folder settings/privacy/photos. Can you help with accessing this folder? Thanks
     
  8. JSingr macrumors member

    Joined:
    Apr 23, 2010
    #8
    It's a known issue..developer is aware..to fix it:

    1. Uninstall PkgBackup
    2. reboot phone (not respring)
    3. Reinstall PKG
    4. Launch PKG (you can let it analyze) then press home.
    5. go to settings..try the iCloud backup and it should work. PKG will work as well.
     
  9. capt601 macrumors member

    Joined:
    Jun 27, 2008
    #9
    still doesnt work for me. on ipad and iphone. i like this app for backups but it is a lot of work trying to get it to work. not sure if it is worth it.
     
  10. JSingr macrumors member

    Joined:
    Apr 23, 2010
    #10
    What is the error you're getting with iCloud?

    I missed a last step. Turn off then on iCloud backup
     
  11. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #11
    I don't think he means in iFile. I think he means just open the settings app then privacy then photos. I could be wrong though.
     
  12. capt601 macrumors member

    Joined:
    Jun 27, 2008
    #12
    Finally late last night, after doing it the exact same way each time, the 17th and 19th time was the charm. Didn't do anything different but was able to get both devices to backup to icloud.
     
  13. JSingr macrumors member

    Joined:
    Apr 23, 2010
    #13
    actually a simpler fix just discovered is to enable "activate" in settings/pkgbackup to reset all settings.
     
  14. JazJon macrumors newbie

    Joined:
    Aug 14, 2008
    #14
    EXCELLENT ! I was about to lose hope until I dug deeper into searching for answers. Bam fixed!!

    (animation) Backing Up...
    Estimating time remaining... (About 6 hours remaining)
    So far so good!!!

    P.S. don't forget to turn iCloud backup OFF then ON again for it to finally work again.

    Oh, I didn't try this method, oh well what ever works! I'll try this way if it happens again.
     
  15. Fofer macrumors 6502a

    Joined:
    Oct 24, 2002
    #15
    Thank you for this thread, and the answers contained therein. My iPhone 5 was backing up to iCloud, but my iPad mini had stopped. It would try, and then fail pretty quickly. "iCloud backup could not be completed." And no amount of voodoo would get it working again. I was getting frustrated and almost ready to give up. (Restoring wasn't an option really as I am jailbroken on iOS 6.1.2 and now only iOS 6.1.3 is being signed.)

    One related symptom I noticed was that when I would go to "Settings -> iCloud -> Manage Storage -> iPad mini" (in the hopes of toggling off Photo backup, at least temporarily,) the wheel would spin and it would never actually show the list of toggles. It would just sit on that screen forever. I knew that if I couldn't fix that, then the backup would never complete. And it never did... I tried lots and lots of things:

    I deleted the old backup, toggling iCloud off and on again, both via iTunes as well as on the device itself (countless times)
    I uninstalled PkgBackup (even though it was updated recently to fix this conflict)
    I uninstalled a bunch of other non-essential Cydia tweaks
    I deleted all of the photos on my iPad mini
    I deleted my iCloud account and added it back (first as mac.com, then as icloud.com, then again as mac.com)
    I ran iCleaner Pro and removed unused dependencies
    I rebooted the iPad mini (countless times)
    I sacrificed a black goat while chanting prayers in the name of Cupertino

    ...and nothing worked.

    It was only when I reinstalled PkgBackup, in the hopes of following the tips in this thread, that I was FINALLY able to get it fixed. I didn't have to grant access to photos again, I didn't have to "activate" in settings. I merely reinstalled PkgBackup and ran a single backup there. And then went back to Settings -> iCloud and manually started a backup.

    And it is currently performing that backup, with "about 16 minutes remaining."

    Huzzah! Thanks for the push, gang. I feel a lot better knowing automatic wireless iCloud backups will be operational.
     
  16. vajeff macrumors member

    Joined:
    Jan 30, 2011
    #16
    I had the same exact issue too, and this worked like a charm! Thanks, backing up right now.

     

Share This Page