iCloud.com says that 'Browser Zoom Level Not Supported'

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by horace528, Dec 15, 2011.

  1. horace528 macrumors regular


    May 14, 2011
    Hello Macrumors Forums
    I have a issue with iCloud.com, where it says that the Browser Zoom level is not supported, and for best results, go to 100%.
    I am on Google Chrome, and I am on 100%!:confused::confused:
    But it says that to Zoom to 100%.
    Any solutions?
    A Screenshot will be uploaded.

    Attached Files:

  2. Wicker macrumors regular

    May 11, 2008
    Newcastle upon Tyne, UK
    This happened to me today as well, very strange! Chrome at 100% as well...
  3. doublecee macrumors newbie

    Jan 2, 2012
    I had the same until I deactivated extensions and themes in Chrome.

    Then I installed the Amazon Wishlist extension and it started to happen again. However, in the amazon widget options, I deactivated the animation option, and normal service has been resumed. To be honest, Im happier without all the extensions and the lack of an animated Amazon logo when browsing on line stores isnt something that bothers me.

    Im pretty confident if you deactivate those extensions and themes (if you are using any) will resolve your 100 % zoom issues
  4. Daveoc64 macrumors 601

    Jan 16, 2008
    Bristol, UK
    I have one question:

    Why does iCloud require a specific zoom level? That's terrible from an accessibility point of view.

    It shouldn't be checking that at all - let alone having a fancy dialog ready to go.

Share This Page