Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

celebron

macrumors newbie
Original poster
Nov 4, 2016
3
0
I just bought MBP 2017 with custom configuration. After icloud setup i realized my device shows as just mac and uses generic mac icon(macOS logo) both in iOS AND macOS icloud device list. It should show up as Macbook pro and should use appropriate MBP icon.
However i can see correct icon and device model in icloud web page device list.
I tried signing out and sigin in again but nothing changes.
It a minor issue bu kinda annoying for me. Anyone have an idea?
 

MALmen

macrumors regular
Aug 11, 2011
133
148
I just bought MBP 2017 with custom configuration. After icloud setup i realized my device shows as just mac and uses generic mac icon(macOS logo) both in iOS AND macOS icloud device list. It should show up as Macbook pro and should use appropriate MBP icon.
However i can see correct icon and device model in icloud web page device list.
I tried signing out and sigin in again but nothing changes.
It a minor issue bu kinda annoying for me. Anyone have an idea?

Same for my custom MBP
 

frogcjn

macrumors newbie
Sep 16, 2014
22
16
got the same issue with my customized mbp
Same ISSUE!!

屏幕快照 2018-03-30 19.27.07.png


https://discussions.apple.com/thread/8027277
 
Last edited:

4254126

Cancelled
Jun 20, 2017
828
855
My 27'' iMac is apparently only a 21,5'' iMac... but strangely only on iCloud.com. In the iCloud preferences on iOS/Mac all the data is correct, just as on the Apple ID website. Weird.
 

Laughinggravy

macrumors newbie
May 14, 2018
2
0
My 27'' iMac is apparently only a 21,5'' iMac... but strangely only on iCloud.com. In the iCloud preferences on iOS/Mac all the data is correct, just as on the Apple ID website. Weird.


I have the exact same problem. My icloud is showing my new 27" 5k retina display imac as a 21" inch imac. No big deal, just very annoying. No one has an answer for this?
 

frogcjn

macrumors newbie
Sep 16, 2014
22
16
I have the exact same problem. My icloud is showing my new 27" 5k retina display imac as a 21" inch imac. No big deal, just very annoying. No one has an answer for this?
Whether your iMac is with custom configuration?
You may contact Apple support, to let them know you have a custom configuration iMac and not showing the right model.

Now my MacBook Pro 2017 with custom configuration is showing the right icon on https://appleid.apple.com/.


屏幕快照 2018-05-15 13.58.20.png
 
Last edited:

terrencez

macrumors newbie
Aug 1, 2018
2
0
Same issue with my MBP 2018, so annoying
upload_2018-8-1_22-36-43.png

[doublepost=1533134306][/doublepost]
Whether your iMac is with custom configuration?
You may contact Apple support, to let them know you have a custom configuration iMac and not showing the right model.

Now my MacBook Pro 2017 with custom configuration is showing the right icon on https://appleid.apple.com/.


View attachment 761778
I've contacted Apple support, but it doesn't work.
 

Shanghaichica

macrumors G5
Apr 8, 2013
14,608
13,099
UK
My MBA is a 2014 model but shows up as a 2013 model in iCloud.

On the air it’s clearly a 2014 model though.
 

Elektrofone

macrumors 65816
Jul 5, 2010
1,030
480
Anyone find a way to resolve this? I contacted Apple Support, but after weeks of them going silent I don't think I'm going to get a response.
 

gj835

macrumors newbie
Dec 1, 2017
7
2
Anyone find a way to resolve this? I contacted Apple Support, but after weeks of them going silent I don't think I'm going to get a response.

Same experience before, then I send an email to Tim Cook and Craig complaining about this then somebody call me and fix the problem, funny.
 

Elektrofone

macrumors 65816
Jul 5, 2010
1,030
480
Same experience before, then I send an email to Tim Cook and Craig complaining about this then somebody call me and fix the problem, funny.

Really... I'm gonna send an e-mail. I know it's not really affecting anything, but it is concerning that the information isn't correct in their databases.
 

Siebastjan

macrumors newbie
Sep 14, 2018
8
0
Sydney, Australia
Having the exact same issue with my newly purchased custom 2018 MacBook Pro. I find it interesting that most of the users going through this issue are dealing with custom devices, possibly there is a correlation? The issue is more petty than anything but it just makes no sense to me why the model name and icon are not registering correctly with Apple's database and hence it's getting me quite concerned. I'm waiting to see if possibly MacOS Mojave will be able to correct this, otherwise I hope someone will have a solution soon!
 

Elektrofone

macrumors 65816
Jul 5, 2010
1,030
480
Having the exact same issue with my newly purchased custom 2018 MacBook Pro. I find it interesting that most of the users going through this issue are dealing with custom devices, possibly there is a correlation? The issue is more petty than anything but it just makes no sense to me why the model name and icon are not registering correctly with Apple's database and hence it's getting me quite concerned. I'm waiting to see if possibly MacOS Mojave will be able to correct this, otherwise I hope someone will have a solution soon!

Yeah I definitely think it has to do with it being a custom model. Although, I wouldn’t hold your breath for Mojave fixing it. I am on the GM release and haven’t had any luck with it being fixed.
 

Elektrofone

macrumors 65816
Jul 5, 2010
1,030
480
Interesting development. It's changed from being a generic device to now being listed as a 13" Model. I guess its progress, but its still not the right device.

h9OBtqB.png
 

Siebastjan

macrumors newbie
Sep 14, 2018
8
0
Sydney, Australia
Interesting development. It's changed from being a generic device to now being listed as a 13" Model. I guess its progress, but its still not the right device.

h9OBtqB.png
That is so bizarre mine just did the same thing... My 15inch device is now showing up as 13"? I wonder what is going on?
 

Attachments

  • Screen Shot 2018-09-16 at 11.33.19 am.png
    Screen Shot 2018-09-16 at 11.33.19 am.png
    115.7 KB · Views: 196

Siebastjan

macrumors newbie
Sep 14, 2018
8
0
Sydney, Australia
I noticed that it showed up properly on iCloud.com Does it do that for you too?
Yes I did notice it still shows up correctly on iCloud.com. Interestingly, I also checked what my device list looks like on the Apple Support app on my iPhone in which it displays the wrong icon of what appears to be a pre 2010 MacBook Pro even though i have the latest 2018 model. Did you also find that to be the case for you? The model name is also incorrect, still showing 13" as opposed to 15" in which i will attach a screenshot below to show you.

IMG_7052.PNG

I was also able to give Apple Support a call today in which I was told that Apple is aware of the issue and are working to try resolve it. The consultant also confirmed with me that the issue is primarily affecting users with custom devices for some unknown reason. On a side note, if anyone here is going through the same issue and hasn't done so already, I encourage you to call Apple Support to mention that you are experiencing this issue. The more people report it, the more awareness this problem will attain which will hopefully prone Apple to resolve it quicker. However, today was quite refreshing to see that at least the icon on the Apple ID site was correct and only the model was incorrect. Hopefully thats a sign that Apple is doing something about it.
 

1050792

Suspended
Oct 2, 2016
2,515
3,991
Didn’t realize this thread, the same issue is also happening to me. My MBP 15” is showing up as 13” even on iCloud.com.
 

Elektrofone

macrumors 65816
Jul 5, 2010
1,030
480
Yes I did notice it still shows up correctly on iCloud.com. Interestingly, I also checked what my device list looks like on the Apple Support app on my iPhone in which it displays the wrong icon of what appears to be a pre 2010 MacBook Pro even though i have the latest 2018 model. Did you also find that to be the case for you? The model name is also incorrect, still showing 13" as opposed to 15" in which i will attach a screenshot below to show you.

View attachment 782204

I was also able to give Apple Support a call today in which I was told that Apple is aware of the issue and are working to try resolve it. The consultant also confirmed with me that the issue is primarily affecting users with custom devices for some unknown reason. On a side note, if anyone here is going through the same issue and hasn't done so already, I encourage you to call Apple Support to mention that you are experiencing this issue. The more people report it, the more awareness this problem will attain which will hopefully prone Apple to resolve it quicker. However, today was quite refreshing to see that at least the icon on the Apple ID site was correct and only the model was incorrect. Hopefully thats a sign that Apple is doing something about it.

Oh good to know that they’re working on it. Yes it is showing the wrong model and icon on the Apple support app.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.