iCloud down?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Morac, May 21, 2015.

  1. Morac macrumors 6502a

    Morac

    Joined:
    Dec 30, 2009
    #1
    The iCloud status page shows all green, but suddenly I'm randomly getting password prompts for my iCloud password on my iPhone and iPad. If I go into the iCloud settings, I get either server errors or wrong password errors.

    It looks like iCloud is down, but the status page shows all green.
     
  2. sbojevets macrumors member

    Joined:
    Feb 7, 2009
    Location:
    The Arctic
  3. Kajje macrumors 6502a

    Kajje

    Joined:
    Dec 6, 2012
    Location:
    Asia
    #3
    Same here. All mac users at the office got notification that their icloud was not connecting and to review their settings.
     
  4. heogia macrumors newbie

    heogia

    Joined:
    Sep 15, 2013
    #4
    Same here. iCloud is down

    Same here. It prompts me to logon for about 30 min. Then, I was able to logon after one hour but iCloud mail and storage is remaining down for me. Problems happened around midnight Pacific time.
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
  6. Kajje macrumors 6502a

    Kajje

    Joined:
    Dec 6, 2012
    Location:
    Asia
    #6
    Now the iphones and ipads also start asking for passwords to login to icloud.
     
  7. GrindedDown macrumors 6502a

    Joined:
    Jun 4, 2009
    Location:
    Las Vegas
    #7
    Yeah I am getting it on all my devices right now. Meh, hopefully it will be back soon, but good to know it isn't just me.
     
  8. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #8
    Hmm..

    Sounds like 10.10.4 is coming out at 10AM
     
  9. ollie87 macrumors member

    Joined:
    Jun 29, 2012
    Location:
    Nottingham, UK
    #9
    Are you all using Two-Stage Authentication? Seems to be an issue around that, I contacted Apple Support about it.
     
  10. Kajje macrumors 6502a

    Kajje

    Joined:
    Dec 6, 2012
    Location:
    Asia
    #10
    Probably the status of the down status server, is down. The person responsible for monitoring the status of the down status server down status is to be called for reporting down at the down status server department as we speak.
     
  11. macpeach55 macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #11
    Same here

    I am in Germany & cannot get to my mail on any device or through the cloud - there it says the "can't load mail". The problem board is green here as well.

    Feel a little better that it isn't just me!
     
  12. Kajje macrumors 6502a

    Kajje

    Joined:
    Dec 6, 2012
    Location:
    Asia
    #12
    I see people from the US, New Zealand, Singapore, Germany, UK in this thread. That's potentially a lot of fried servers we're talking about.
     
  13. heogia macrumors newbie

    heogia

    Joined:
    Sep 15, 2013
    #13
    Some of the iCloud services now turn yellow on the Apple iCloud status page with the notation: "Service may be slow for some users." That includes Mail, Backup, Keychain, iCloud drive, Find my Mac (phone, iPad, etc.), Document in iCloud, Back to my Mac, etc.
     
  14. macpeach55, May 21, 2015
    Last edited: May 21, 2015

    macpeach55 macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #14
    Yep, same for the Status page here - I like the "Service may be slow" - any slower, & it would be in reverse.
    ;)
     
  15. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
  16. Kajje macrumors 6502a

    Kajje

    Joined:
    Dec 6, 2012
    Location:
    Asia
    #16
    We have 10.10.2 / 10.10.3 and several flavours of 8.0 until 8.3 around with both normal and Two-Stage Authentication accounts.

    All down.

    So for macpeach55: sorry to inform you you've just been 'outsupported' by Apple support...
     
  17. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #17
    Reason I ask is I'm using 10.10.4 and IOS 8.4 and I have no problems.

    So I think Apple is getting ready to release 10.10.4 and IOS 8.4
     
  18. Kajje macrumors 6502a

    Kajje

    Joined:
    Dec 6, 2012
    Location:
    Asia
    #18
    Hahaha
    Welcome to the mandatory forced update service. It's like the app killswitch but then better.

    Eurm Apple. One needs icloud for installing a new IOS version.

    So anybody who hasn't upgraded their IOS yet to 8.4 please keep the environment in mind while disposing your useless idevices into the trashcan :D:D:D
     
  19. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #19
    My "Notes" have vanished off both of my devices. Hopefully they come back...

    Edit: 10.10.3 and 8.4.
     
  20. macpeach55 macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #20
    I feel let down :)

    ----------

    I don't think it is hitting a whole lot of people, otherwise one could hear the screams through the window.

    Either they ARE updating something or someone spilt their coffee on the BIG panel
     
  21. ollie87 macrumors member

    Joined:
    Jun 29, 2012
    Location:
    Nottingham, UK
  22. macpeach55 macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #22
    Everything still down for me, but a least that's a good sign :)
     
  23. macpeach55 macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
  24. Kajje macrumors 6502a

    Kajje

    Joined:
    Dec 6, 2012
    Location:
    Asia
    #24
    Here too. Just in time for closing the office.
     
  25. madasasnake macrumors newbie

    Joined:
    Jun 8, 2010
    #25
    Mine resolved for a couple of hours but has now gone again!
     

Share This Page