iCloud Drive missing files

GeekBell

macrumors newbie
Original poster
Apr 25, 2016
6
0
I upgraded to MacOS Sierra. I was expecting all the folders I created to populate in iCloud drive. Nothing. The default folders synced but nothing else did. I see all of it on iCloud.com, but not on my MacOS. Anyone else experiencing this? Have you figured out the issue yet?
 

blasto2236

macrumors 6502a
Nov 4, 2012
768
372
Not quite sure what you mean. Only files in the Desktop or Documents sync to iCloud in macOS, they should still be showing in Finder under the iCloud section, beneath iCloud Drive. There should also be subfolders for Desktop and Documents in the iCloud Drive folder on all devices.
 

GeekBell

macrumors newbie
Original poster
Apr 25, 2016
6
0
The folders are all there. Almost like I just started using iCloud Drive: Desktop, Documents, Pages, etc. If I log into iCloud.com the folders are all there + 15 more folders that are not syncing. I'll call apple support and see what they say since no one has replied to this thread.
 

archvile

macrumors 6502
Oct 27, 2007
463
587
The folders are all there. Almost like I just started using iCloud Drive: Desktop, Documents, Pages, etc. If I log into iCloud.com the folders are all there + 15 more folders that are not syncing. I'll call apple support and see what they say since no one has replied to this thread.
Turn iCloud Drive off in iCloud options and turn it back on?

Is "Optimize Mac Storage" turned on in the iCloud Drive settings?
 

blasto2236

macrumors 6502a
Nov 4, 2012
768
372
Turn iCloud Drive off in iCloud options and turn it back on?

Is "Optimize Mac Storage" turned on in the iCloud Drive settings?
Even if it is, the placeholders for the files should still be there so they can be downloaded.
 

GeekBell

macrumors newbie
Original poster
Apr 25, 2016
6
0
I contacted apple support and they couldn't figure it out. I turned off iCloud Drive, removed the files, and turned it back on. Unchecking Optimize storage space didn't make a difference either. The funny part is that when I save a file to my desktop... it syncs... then disappears from my desktop... it does show up in iCloud.com after it disappears from my desktop.
 

blasto2236

macrumors 6502a
Nov 4, 2012
768
372
I contacted apple support and they couldn't figure it out. I turned off iCloud Drive, removed the files, and turned it back on. Unchecking Optimize storage space didn't make a difference either. The funny part is that when I save a file to my desktop... it syncs... then disappears from my desktop... it does show up in iCloud.com after it disappears from my desktop.
Are you syncing multiple Macs to iCloud? If so, that is how the feature is designed to work.
 

davecom

macrumors member
Aug 10, 2009
76
0
I'm having the same issue but with files in my Documents & Desktop folders. They synced from one Mac but are simply not downloading on the other.

Edit: Just after I wrote this they started downloading. Maybe they just auto-check every 15 minutes or something. Give it a few minutes if you're concerned.
 

GeekBell

macrumors newbie
Original poster
Apr 25, 2016
6
0
Are you syncing multiple Macs to iCloud? If so, that is how the feature is designed to work.
It's designed to disappear from your Desktop when you save a document? I am not using multiple Macs. just one. All the iCloud Documents show up on my iPhone like they should.
 

nj1266

macrumors 6502a
Jan 15, 2012
632
137
Long Beach, CA
When Apple says files on the Desktop can sync with iCloud does that include folders on my Desktop as well? What is included in Desktop?
 

gamephase

macrumors newbie
May 22, 2018
1
0
iCloud is literally a virus. Been trying to get rid of it for days. Once I do it's gone for good.