iCloud Drive stuck on "Setting up iCloud Drive" for hours

Discussion in 'OS X Yosemite (10.10)' started by Azzin, Oct 18, 2014.

  1. Azzin macrumors 68040

    Joined:
    Jun 23, 2010
    Location:
    London, England.
    #1
    Hi all, as per title really.

    I installed Yosemite this morning and one of the first things I did was top open Finder to get look at iCloud Drive, but it's been stuck showing "Setting Up" for hours now.

    Just me?
     
  2. ajo macrumors 6502

    Joined:
    Jan 28, 2006
    #2
    Mine took a little while too. All set up now. I can't remember but I think a restart might have helped.
     
  3. vahnx macrumors member

    Joined:
    Oct 13, 2009
    #3
    Mines has also been "Setting up" for half an hour+ now.
     
  4. superdx macrumors regular

    Joined:
    Jul 23, 2009
    #4
    I restarted and it completed instantly, give that a try
     
  5. Azzin thread starter macrumors 68040

    Joined:
    Jun 23, 2010
    Location:
    London, England.
    #5
    Did the trick for me too, thanks.
     
  6. Doga macrumors regular

    Doga

    Joined:
    Dec 15, 2003
    Location:
    Near Montréal, Canada
    #6
    Try signing out of iCloud in the System Preferences > iCloud panel, and then sign back in again. You may have to delete the iCloud account then recreate it in order to sign in again. This solved the constant updating... thing for me, whereas restarting my iMac didn't.
     
  7. richard13 macrumors 6502a

    Joined:
    Aug 1, 2008
    Location:
    Mill Creek, WA
    #7
    No, you aren't the only one. I installed Yosemite yesterday and it was still saying "Setting up..." even this morning. Really? Anyway...

    Didn't work for me:
    • Signed into my iCloud account (have no idea how I was signed out)
    • Rebooted
    • Shutdown/Startup

    Seems to have fixed it:
    • Logged completely out of iCloud deleting all the data it was storing on my computer
    • Logged back in and needed to get approval from another device (iPhone).

    I no longer have "Setting up..." and iCloud drive seems to be working normally now.

    Good luck!
     
  8. pmicou macrumors newbie

    Joined:
    Mar 11, 2015
    #8
    What worked for me at last was

    1) Uncheck 'iCloud' under System Prefs/iCloud
    2) Restart Mac
    3) Check 'iCloud' under System Prefs/iCloud

    Immediate success. I hope this works for others.
     
  9. tlever macrumors newbie

    tlever

    Joined:
    Sep 9, 2017
    #9
    --- Post Merged, Sep 9, 2017 ---
    No - new IMAC - same thing iCloud set up hangs on sign in screen for hours - only way forward is compete re-boot....

    or is it?
     

Share This Page