iCloud duplicated iCal events //

Discussion in 'iOS 5 and earlier' started by M-5, Oct 14, 2011.

  1. M-5 macrumors 65816


    Jan 4, 2008
    So iCloud is set up on my Mac running Lion. I also set it up on my iPhone 4; I have yet to set it up on my iPad 2, since I don't want to upgrade to iOS 5 and lose my jailbreak.

    The problem I had was that when I synced everything up, I ended up with duplicate events in my calendar: the events shown from my "on my mac" calendar, and the same events displayed again from my "iCloud" calendar.

    It became confusing, so I did a little bit of "housekeeping" and decided to change the setting on iCal to delete events older than 30 days. Then I tried to delete all of the events from the "on my mac" calendar, since I assume I only need to have the ones in iCloud now since they're the same events.

    I suppose this distinction of "on my mac" calendars and the "iCloud" calendars help those who don't want their calendars to mirror each other, but I do so I assume I'm doing it correctly.

    There is one recurring event which I can't delete however. I've deleted all of my recurring events, but one of them seems to just stay there no matter what I do. I also am not sure what my "Gmail to do" calendar is or how to remove it.
  2. Munnichs macrumors member

    Mar 30, 2011
    Yep I had the same, also got every contact double in Whatsapp. Kinda annoying.
  3. M-5 thread starter macrumors 65816


    Jan 4, 2008
    This is so frustrating. On my iPhone I have one events showing up three times under three different calendars:
    For instance, if an event is under my "School" calendar, it will show up as an event from my Mac under the "school" calendar as well as a duplicate "school[xxx@mac.com]" calendar from my mac, and a final time from my "school" calendar from iCloud.

    I don't understand why it's showing up twice from calendars from my Mac if I deleted those events on my mac. I also clicked the box in iTunes to replace the calendars on my iPhone for the information on my Mac, so it should delete the event!
  4. maliu macrumors 6502a

    Jun 24, 2010
    What I do to get rid of duplicates(I don't use iCloud) is to sync, it will report conflicts. Pick the one you won't to keep and tell it o apply to all. It will at least get rid of the duplicates. For now.
  5. xraydoc macrumors 604


    Oct 9, 2005
    If you're using a Mac, check the iCal app. Make sure you don't have a duplicate MobileMe/iCloud account added to the app on top of the one activated in the MobileMe and/or iCloud system preference control panel.

    Check: iCal -> Preferences -> Accounts
    Make sure only one copy of your iCloud credentials are in there, not two.
  6. hollerz macrumors 6502a


    Sep 13, 2006
    Durham, UK
    In iTunes, uncheck "Sync iCal Calendars" in the iPhone sync info bit. Calendars from iCloud will still sync but it won't import them from your mac (which is why you're getting duplicates).
  7. ehpedro macrumors newbie

    Jun 11, 2007
    Notification Center (only) calendar duplicaion

    Not sure how common this is but all my calendar events are duplicated, but only when I swipe down and enter notification centre (ie they are not duplicated in the iCal app). Anyone know why this would be, seriously annoying!

    The other gripe is when you double tap a photo from the photo app it zooms in waaaay too far...

    All help mucho appreciated as always :)
    iPhone 4 btw...
  8. b17777 macrumors member

    Jul 14, 2008
    St.Paul MN
    I'm getting the same thing and I don't have that checked in iTunes
  9. b17777 macrumors member

    Jul 14, 2008
    St.Paul MN
    Ok, I think I figured it out.
    In iTunes I
    Checked "Sync iCal Calendars"
    Checked "Selected Calenders " But did not select ANY calenders
    Under Advanced
    Checked "Replaced information on this phone Calendars"
    Unchecked "Sync iCal Calendars"
    When it asked to remove or delete calendars say yes
    And now everything is working as it should.:)
  10. airkevin macrumors newbie

    Oct 15, 2011
    It's easy to fix the duplicate entries caused by iCal / iCloud. They are not really duplicated, you are just looking at identical calendars stored on both your computer and on iCloud: (on Lion)

    Go online to iCloud.com and see if the entries are also duplicated there. If they are NOT duplicated, and look ok:

    Go to iCal on your computer and click the "Calendar" button on the upper left corner of the faux leather strip. Unclick all the calendars under the section that says "On my mac" but leave all the "iCloud" entries checked.

    Good to go..

  11. AuroraProject macrumors 65816


    Feb 19, 2008
    Right there
    This. I was getting duplicates too, I had tried removing and reapplying iCloud settings. Only this fixed my issue.
  12. M-5 thread starter macrumors 65816


    Jan 4, 2008
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    I deleted all my entries that were under the "On my Mac" calendar and started over on iCloud. It didn't take too long since I just had to do a week of recurring calendars.

    I also went into the system preferences in iCal on my Mac and changed it so that the default calendar when I create something is the "iCloud" calendar rather than under the "On my Mac " calendar. I also changed the default Reminders to iCloud.
  13. Meblackstone macrumors newbie

    Oct 15, 2011
    How to restore calendar on mac

    I had the duplicate calendar items on my phone and didn't realize until now that one was icloud and one was from my mac. So, I deleted one set manually and I guess I deleted the ones from my mac. How can I get those back on my mac calendar? I use it all the time and tried syncing my phone again but they are not getting back on my mac calendar. What am I missing? Thanks for your help!
  14. Kenwood macrumors newbie

    Mar 30, 2011
    THANK YOU!!!! Totally fixed my problem.

Share This Page