iCloud Email consistency?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by tomf, Dec 15, 2011.

  1. tomf macrumors regular

    Joined:
    Nov 11, 2009
    #1
    Hi All,

    So i put Lion on my Mac Pro and my Macbook Pro yesterday, (i also have OS5 on iphone4S) - but i'm having a hard time getting my email accounts to stay synced/consistent with each other.

    E.g - when i send a mail from my mac pro, i would like to see that mail in the sent folder on all 3 devices. Similarly, i deleted a mailbox folder on my mac pro mail, yet on my macbook pro mail the folder was still there.

    (I'm coming from mobileme, if that makes any difference)

    All i want is for my mail to be consistent across my 3 devices, so that when i send/move/ etc emails then all my devices stay consistent with each other.

    I have turned icloud on on all 3 devices, and selected 'mail & notes' on them all.

    Am i doing something wrong? Is it not possible to keep these 3 consistent and the same?

    Thank you for any help or advice,

    Elastic
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I use one iCloud mail account on two Macs, one iPhone, one iPad, and one iPod Touch and it syncs perfectly between all of them.
     
  3. tomf thread starter macrumors regular

    Joined:
    Nov 11, 2009
    #3
    So if you were to send an email from your phone, it would show up in the sent folder on your mac?
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Yep.
     
  5. tomf thread starter macrumors regular

    Joined:
    Nov 11, 2009
  6. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #6
    Mine does but my email client settings on my mac have "store sent emails on the server"
     
  7. tomf thread starter macrumors regular

    Joined:
    Nov 11, 2009
    #7
    maybe thats what i need to do?

    Maflynn - is it even possible to have what i want - say i delete a mailbox folder on one device, then it deletes it on all devices? Or if i send an email on one device then it shows up in the sends folder on all devices?
     
  8. George Knighton macrumors 6502a

    George Knighton

    Joined:
    Oct 13, 2010
    #8
    The way that my iCloud account works, something that I've sent will not necessarily show up on every iOS device unless I've gone to the SENT folder to refresh it.

    It seems to me that the Inbox is the only mail folder that pushes, and even then the mail count's red balloon icon will be incorrect much of the time.

    It works reliably enough for me to be satisfied with a free mail account. Google Mail's Exchange server doesn't work any better, in my opinion.
     
  9. tomf thread starter macrumors regular

    Joined:
    Nov 11, 2009
    #9
    I agree George, thats exactly the way i'm seeing things - The only thing that syncs/pushes is the inbox, and as you say, the red badge on that doesn't update itself regularly, only until you open the mail app will it correct itself.
     
  10. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #10
    You want it setup like the below cap to store all messages on the IMAP server.

    [​IMG]

    ...and yes, if you delete a folder in one place it will delete it on all devices.
     
  11. tomf thread starter macrumors regular

    Joined:
    Nov 11, 2009
    #11
    Thanks weasel, my settings are exactly the same.

    I'm still having the same problem though - I'm sending emails on my mac pro - but they are not showing up on my macbook pro sent folder.
     
  12. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #12
    If you have it setup that way on each machine it should work. How about try rebuilding the mailboxes. Select the sent folder then go to the mailbox menu and select rebuild. Do that for each folder on both machines then restart Mail app.
     
  13. tomf thread starter macrumors regular

    Joined:
    Nov 11, 2009
    #13
    Weasel you're a genius! Job done! Thanks :)

    Now one final quick question, save me opening a new thread -

    Since i moved from MobileMe to iCloud, when i send a new mail, it now sends from xxxx@me.com and not my normal xxxx@mac.com

    Any ideas why or how to make it just send from my @mac.com address?

    I'd rather just keep things simple and keep using my xxxx@mac.com address you see.

    ----------

    Ok, small problem - my 2 macs are now showing the same sent messages, but my iPhone is not.

    I can't see where to set it on the iPhone so that 'Store sent messages on the server' is selected?
     
  14. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #14
    Go to this panel in mail prefs and add the xxx@mac.com address. Then when you send a new mail there will be a drop down just below the subject field where you can select which address to use.

    [​IMG]

    There is no setting for saving sent in iOS, it just does it by default.
     
  15. tomf thread starter macrumors regular

    Joined:
    Nov 11, 2009
    #15
    Weasel i cannot thank you enough, works a treat now.

    Re: the iOS mail 'sent' - i just went to settings/mail,contacts,calendars/xxxx@mac.com/account/mail/advanced - then changed sent mail to 'on the server - Sent' instead of 'on my iPhone - sent'
     
  16. MikeRus macrumors newbie

    Joined:
    Jan 6, 2012
    #16
    Hello. When I setup email on my Mac under the your instructions, I didn't see sent emails in "Sent" (in the horizontal bar), now I can see them in left section under the iCloud IMAP sent folder... It's not really convenient for me. Is there a way how to store messages on the server and see it in "Sent" in the horizontal bar?
     
  17. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #17
    Click on the Sent folder to highlight it. Then go to Mailbox->Use this mailbox for->Sent

    It should then move to under your inbox (you may have to quit and relaunch the mail app)
     
  18. MikeRus macrumors newbie

    Joined:
    Jan 6, 2012
    #18
    So easy! Thank you very much! I looking for solution one week...
     

Share This Page