iCloud email on Android - help?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by chenks, May 25, 2013.

  1. chenks macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #1
    need to set up my icloud email on android device (nexus 4).
    i've googled a few places that give instructions but none seem so to work.

    configuring it as IMAP, but does anyone have a known working set of instructions?
     
  2. parapup macrumors 65816

    parapup

    Joined:
    Oct 31, 2006
    #2
    Ah - Nexus devices always have problems with automatic email setup - on my Samsung Note 2 - I just had to enter my iCloud email and password - it figured out the rest! Anyway here are the settings -

    If these settings don't work for you - Google messed up, open a bug report and watch them do nothing. (Google stock mail really sucks for third party stuff.)
     
  3. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #3
    Can't safely connect to server.
    (Certificate hostname not useable for server : mail.me.com)

    my desktop client (mail.app) uses "p04-imap.mail.me.com" as the incoming mail server.
     
  4. parapup macrumors 65816

    parapup

    Joined:
    Oct 31, 2006
    #4
    You might need to accept all certificates unfortunately - I hate to do it as it is a security risk but like I said - mail setup sucks on stock.
     
  5. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #5
    it didn't ask me to accept any, that's the error i got when i clicked next after entering the incoming settings.
     
  6. parapup macrumors 65816

    parapup

    Joined:
    Oct 31, 2006
    #6
    I don't have a stock Nexus device to confirm but if I remember correctly - it is a checkbox that you have to check after going to manual setup.

    Edit : Like this
    [​IMG]
     
  7. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #7
    A simple search of Apple's support site would have brought you rather quickly to iCloud: Mail server information.
     
  8. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #8
    doesn't work though.
    incoming settings are accepted.
    outgoing produces an error (tried both SSL options).

     
  9. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
  10. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #10
  11. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #11
    this is the error i get when trying to confirm the outgoing SMTP settings (incoming settings are accepted)

    [​IMG]
     
  12. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #12
    Did you try the TLS settings instead?
     
  13. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #13
    yes tried both SSL and SSL/TLS
    apparently someone has it working using START/TLS rather than SSL.
     
  14. s.horsfield, May 29, 2013
    Last edited: May 29, 2013

    s.horsfield macrumors regular

    Joined:
    Apr 3, 2011
    Location:
    New Zealand
    #14
    Same issues I'm getting on my Android phone (running 2.2 Huawei skinned Android, I'm waiting for the 5S). I had a Nexus 4 for 4 months or so (before selling it, waiting for 5S as I said). If I recall correctly Apple's iCloud server settings were broken then (when I initially bought the Nexus 4). After searching around I found a thread that fixed my issues (a couple of slight settings changes basically). A few months down the road my outgoing mail stopped working, however the mail was already setup so I could at least receive, at a guess I would assume this was when the SSL handshake errors started happening. I can't find a fix anywhere for these issues

    EDIT: Since using "TSL: Accept all certificates" things are working fine!
     
  15. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
  16. smartypantsguy macrumors newbie

    Joined:
    Feb 24, 2004
    Location:
    New York City
    #16
    I can confirm this. For WHATEVER reason, it has to be set to START/TSL in order for smtp to work.

    Took me a bunch o' tries to figure it out. Thanks APPLE !
     

Share This Page