iCloud email showing up in other email servers

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Johnnyjomp, Sep 1, 2015.

  1. Johnnyjomp macrumors newbie

    Johnnyjomp

    Joined:
    Sep 1, 2015
    #1
    Hello everyone. First time posting here, though I have read and learned from many other posts!
    My iCloud id is my email address (for example, joe@abc.com). When email is sent to my iCloud email address, it shows up both in my iCloud in box and in my abc.com inbox. When I check the address it was sent to, it only shows my iCloud address. "Always bcc myself" is turned off. The joe@abc.com address is my main iCloud address because it is my Apple ID

    How do I stop emails sent to my iCloud email from appearing in the abc.com inbox???
    Thanks for any light you can shed on this!
    John
    PS: joe@abc.com is not a real address, just an example!
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    I can think of a few things that would make this happen. One is having forwarding configured at iCloud either by overall forwarding or by a specific rule involving forwarding. It could be a rule in Mail on the Mac to either forward the mail or to copy the mail. Another scenario would be that your joe@abc.com account has the capability to check email at other sources and is configured to do that.

    Have you confirmed that none of these is true?
     
  3. Johnnyjomp thread starter macrumors newbie

    Johnnyjomp

    Joined:
    Sep 1, 2015
    #3
    Hello Brian
    I checked my iCloud and joe@abc.com setups and there is no autoforwarding of emails. In fact, my @icloud.com email isn't listed on my iCloud.com settings anywhere. I checked my iPhone set up and it is not set up to auto cc me.
    I wonder if for some reason, my joe@abc.com inbox on my phone is acting like a universal inbox, displaying both iCloud and @abc.com email
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
  5. Johnnyjomp thread starter macrumors newbie

    Johnnyjomp

    Joined:
    Sep 1, 2015
  6. Johnnyjomp thread starter macrumors newbie

    Johnnyjomp

    Joined:
    Sep 1, 2015
    #6
    No question about it.
    All emails sent to my real icloud.com address are going to the icloud.com address, but are also going to the email address I used to create my Apple ID and therefore icloud id. I have sent an email from my work computer (completely unrelated to any Apple account and to my email address hosted by webhostingpad.com), to my icloud.com email. It arrived at my icloud.com email, but also arrived at my webhostingpad.com email address. I sent and received this using webmail to ensure there was nothing set up on my iphone that would autoforward, cc or bcc emails.
    My icloud and Apple ID accounts have no additional addresses associated with them except the recover address, which is a gmail address and not affected at all by this issue.
    In fact, nothing in my icloud.com nor Apple Id settings mentions my icloud.com address.
    I see nothing in my icloud nor Apple ID settings that would auto-forward emails to any other account.
    So, it seems that my Apple and icloud login name is being treated as an icloud email address.
     
  7. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #7
    When you log into webhosting.com webmail via CPanel do the messages addressed to your icloud.com address appear in the inbox?
     
  8. Johnnyjomp thread starter macrumors newbie

    Johnnyjomp

    Joined:
    Sep 1, 2015
    #8
    Yes, when I check my webmail through cpanel, the icloud emails are there.
     
  9. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #9
    Is it listed when you sign in to Apple ID?
     
  10. Johnnyjomp thread starter macrumors newbie

    Johnnyjomp

    Joined:
    Sep 1, 2015
    #10
  11. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #11
    Then you need to get your Apple ID and associated email addresses straightened out with Apple Support. Sounds to me like there are two Apple IDs involved.
     
  12. Johnnyjomp thread starter macrumors newbie

    Johnnyjomp

    Joined:
    Sep 1, 2015
    #12
    Thanks for all your help. It is a funny situation! I will see if I can figure out how to contact Apple.
     
  13. Johnnyjomp thread starter macrumors newbie

    Johnnyjomp

    Joined:
    Sep 1, 2015
    #13
    Brian... thank you so much for your effort. I just found the solution... hidden away in iCloud.
    I was looking for an autoforwarding setting in iCloud settings, but it is neatly hidden away in iCloud mail settings! I had chosen to autoforward all my icloud email to my non-icloud account. Turned that off now... darn good chance it will help!
    Thanks again for your patience.
    JOhn
     

Share This Page