Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iCloud isn't pushing email on iOS 5

GregElite

macrumors newbie
Original poster
Oct 4, 2011
25
0
iCloud isn't pushing email on iOS 5. Anyone else having this issue? You have to restart it to get any push notifications once.
 

Tom8

macrumors 6502a
Oct 28, 2010
848
71
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

I'm having this issue as well.
 
Comment

GregElite

macrumors newbie
Original poster
Oct 4, 2011
25
0
Thanks. Good to know its defiantly a bug. Wondering if it's a client (iPod) or Server problem?
 
Comment

Tom8

macrumors 6502a
Oct 28, 2010
848
71
Well, i'm on iPhone 4 (GSM) and all my other mailboxes are pushing as usual. I thought it could be something to with iCloud not being officially released yet. But i doubt it since i think it's been working for devs. It could be due to not having the desktop client for iCloud (at least i don't have 10.7.2GM yet), but that seems unlikely.
 
Comment

GregElite

macrumors newbie
Original poster
Oct 4, 2011
25
0
Well, i'm on iPhone 4 (GSM) and all my other mailboxes are pushing as usual. I thought it could be something to with iCloud not being officially released yet. But i doubt it since i think it's been working for devs. It could be due to not having the desktop client for iCloud (at least i don't have 10.7.2GM yet), but that seems unlikely.
I have a iPod touch 4g. Maybe it's a bug on the client side cause it's over wifi? Other than that it has to be there fault. As everything is configured correctly and I have a valid iCloud account.

It pushes your emails once after setting up a iCloud account on iOS5. After that nothing happens.

UPDATE: I've noticed if you leave the mail app opened in the background you'll get your push email with very high latency. If I close the mail app, I no longer receive push emails at all.
 
Last edited:
Comment

xpected_one

macrumors regular
Sep 23, 2008
134
2
Texas
UPDATE: I've noticed if you leave the mail app opened in the background you'll get your push email with very high latency. If I close the mail app, I no longer receive push emails at all.

This is the exact behavior Im getting on my iPhone 4 GSM. Im also a registered dev (iOS only). Although I doubt that matters.
 
Comment

thunderbunny

macrumors 6502a
Jul 15, 2010
616
0
Cheshire, UK
This has been happening intermittently for quite a while for me. Sometimes it doesn't push to iPad, sometimes not to iPhone, sometimes to neither and sometimes to both. I think it's got to be server side.
 
Comment

xpected_one

macrumors regular
Sep 23, 2008
134
2
Texas
This has been happening intermittently for quite a while for me. Sometimes it doesn't push to iPad, sometimes not to iPhone, sometimes to neither and sometimes to both. I think it's got to be server side.

Well it seems to work fine if i keep mail running in the backround. Nothing comes thru at all if i close it fully. I think its a glitch in iOS, because its sending the push notification when mail is open, its just not notifying me when its closed.
 
Comment

GregElite

macrumors newbie
Original poster
Oct 4, 2011
25
0
Well it seems to work fine if i keep mail running in the backround. Nothing comes thru at all if i close it fully. I think its a glitch in iOS, because its sending the push notification when mail is open, its just not notifying me when its closed.

I'm not getting push email at all now. Mail opened or not. I understand it's not officially released but right now this functionality is broken. If it's a glitch in the GM then I don't think this problem will go away until Apple patches it or fixes it before the Oct 12 regular release (witch I find is unlikly). This sucks!!! I might just turn off iCloud all together and gain battery life.

UPDATE: Now it works when mail app is opened. This is a bug.
Can a dev please report this?
 
Last edited:
Comment

ugahairydawgs

macrumors 68030
Jun 10, 2010
2,772
1,807
it's been hit and miss in beta, half the time it wasn't even syncing, kept asking for password. it should be fine when launched next week

Based on Apple's history of online services I wouldn't bet the house on that.
 
Comment

Tom8

macrumors 6502a
Oct 28, 2010
848
71
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

Are there any devs on here that are having this issue?
Or, anyone who isn't having this issue, and iCloud is pushing normally for them?
 
Comment

GregElite

macrumors newbie
Original poster
Oct 4, 2011
25
0
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

Are there any devs on here that are having this issue?
Or, anyone who isn't having this issue, and iCloud is pushing normally for them?

iCloud Push email is now only working when the mail app runs in the background.
 
Comment

Tom8

macrumors 6502a
Oct 28, 2010
848
71
iCloud Push email is now only working when the mail app runs in the background.

Yeah, i saw your previous post about it. I just wanted to know if push mail was actually working for anyone yet. Seems as if it isn't.
 
Comment

joyless

macrumors newbie
Oct 5, 2011
28
0
iCloud push on OS X Mail (10.7.2) is working just fine.
iCloud on iOS 5 Mail is working ok just for the inbox. New mails doesnt get pushed to folders, i have to refresh them manually. Also, if i delete/read new mail on my Mac, it wont be marked as deleted/read on my iPhone, i have to refresh manually. It's working just like in MobileMe, and i was really, really, really hoping it would change in iCloud, but i guess its "working as intended" :(
 
Comment

ugahairydawgs

macrumors 68030
Jun 10, 2010
2,772
1,807
Also, if i delete/read new mail on my Mac, it wont be marked as deleted/read on my iPhone, i have to refresh manually. It's working just like in MobileMe, and i was really, really, really hoping it would change in iCloud, but i guess its "working as intended" :(

Ditto
 
Comment

Tom8

macrumors 6502a
Oct 28, 2010
848
71
It is for me again now.

Came back having had no access to iCloud mail between 2227 last night and about 0930 today. (iWork docs were also down for a bit)

Hmm. I don't think this is an iOS Bug. I think Apple might be doing the final preparations for the big launch on Wednesday and are moving all the servers into place. Or maybe they're rolling them on slowly, because they won't have needed them all online for the developer beta, due to the restricted number of people in it.

iCloud mail is working perfectly on the Mac Mail client and the web based client, it's just not pushing to my iPhone. Strange
 
Comment

HolySalami

macrumors newbie
Jul 3, 2010
23
0
Mine seems to be all working ok now, I did however re-install the GM as part of another problem, but it seems ok now.
 
Comment

GregElite

macrumors newbie
Original poster
Oct 4, 2011
25
0
Mine seems to be all working ok now, I did however re-install the GM as part of another problem, but it seems ok now.
Mine doesn't work ipt4. I tried everything. I mainly think it's just a bug right now.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.