iCloud Keychain not suggesting passwords.

Discussion in 'Mac Basics and Help' started by inscrewtable, Aug 8, 2014.

  1. inscrewtable macrumors 68000

    inscrewtable

    Joined:
    Oct 9, 2010
    Location:
    Australia
    #1
    I have run through numerous online instructions for setting up iCloud Keychain which I have never used, nor have I even used iCloud but I cannot work out what the problem is.

    It appears that icloud is set up correctly on my mac and my ipod as bookmarks have automatically synced across. I have turned all the safari setting on on iOS including keychain and same on Mavericks.

    Apparently when I fill a password field out on iOS I am supposed to have a button on the keyboard where I can have keychain suggest a password, that is not there. And also after I set a password on iOS it does not show up in the field in Safari when I am on the correct page.

    This is most frustrating as it appears to be set up correctly on both devices. I have tried restarting both machines but I have run out of ideas as to why this is not working.

    Any suggestions to try will be welcome.
     
  2. LV426 macrumors 6502a

    Joined:
    Jan 22, 2013
    #2
    There are quite a few websites where Safari has trouble recognising forms used for login purposes. For example, only yesterday I changed my password in Outlook 365's website, but Safari didn't recognise that is was a password update form. So you might have got unlucky with the sites you've tried it with. NB, this often isn't Safari's fault. Plenty of websites get up to dirty tricks in terms of user authentication (the website you're looking at now is one of them).

    Try it on your Mac first of all (as this will be the most capable browser), ensuring that Safari preferences | Passwords | AutoFill user names and passwords is set. iOS has a similar setting.
     
  3. inscrewtable thread starter macrumors 68000

    inscrewtable

    Joined:
    Oct 9, 2010
    Location:
    Australia
    #3
    OK I have been faffing around with this for days now and I have concluded that iCloud keychain does not work. Full stop.

    Even to the point where I used Safari to fill in the password and save it to my icloud keychain but it does not save the password, when I look into keychain access there is no password saved.

    Perhaps they will get it sorted in Yosemite
     

Share This Page