iCloud keychain not syncing on 1 (a Mac) of 4 devices

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Kurwenal, Mar 5, 2014.

  1. Kurwenal macrumors 6502a

    Kurwenal

    Joined:
    Jun 27, 2012
    #1
    I am trying to enable iCloud keychain syncing on four devices: iMac, MacBook Air, iPhone 5s, iPad Air. All devices have the most current OS and are otherwise operating with no issues (including Internet connectivity).

    The iCloud keychain on the MacBook Air is not syncing; passwords saved on the MBA do not sync "up" to iCloud, and passwords saved on any of the other three devices do not sync "down" to the MBA. The other three devices work as they should. The MBA is running 10.9.2 and all other aspects of iCloud work (e.g., contacts syncing, notes syncing). All devices are on the same iCloud account.

    I have tried the following with no success:

    1. Added/removed iCloud from the MBA (many times).

    2. Checked/unchecked the "Keychain" item in Settings>iCloud (many times).

    3. Keychain repair.

    4. Various networks in multiple locations, both WiFi and wired.

    5. The steps outlined in this Apple support document (multiple times): http://support.apple.com/kb/TS4644

    6. Resetting Safari (multiple times).

    7. Various other non-iCloud specific troubleshooting steps like emptying Trash and repairing disk permissions.

    8. Deleting the Ubiquity folder in ~/Library/Application Support (figured it was worth a shot).

    Would greatly appreciate any suggestions.
     
  2. Kurwenal thread starter macrumors 6502a

    Kurwenal

    Joined:
    Jun 27, 2012
    #3
    Thanks for the response. That's the same support note I cited in my question and, unfortunately, those steps haven't solved anything.

    Whole thing is very odd. Apple support has no idea and told me to reinstall the OS.
     
  3. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    You didn't mention throwing away any Preference/Settings files...but I'm pretty sure that you'd be fixed by now with a re-install as it's usually easier to do that than to spend time and effort into tracking down an annoying problem like that.
     

Share This Page