iCloud Keychain won't turn off

Discussion in 'iOS 8' started by Skoal, Jun 9, 2015.

  1. Skoal macrumors 65816

    Joined:
    Nov 4, 2009
    #1
    Running iOS 8.4.4 PB!

    No matter how many times I go to iCloud>keychain and toggle the switch off as soon as I go back a page to the iCloud page it is on again. I get no notifications to save/delete keychain on phone. No notification to input iCloud password etc.

    I've searched the Internet with no luck. Most of what I've found is about OS X. Has anyone run into this issue? I don't want to use keychain on iOS.

    Thanks for any input!
     
  2. Skoal, Jun 9, 2015
    Last edited: Jun 9, 2015

    Skoal thread starter macrumors 65816

    Joined:
    Nov 4, 2009
    #2
    I'm assuming if you add a card to apple pay then keychain defaults to being in use ie. ON? I couldn't find any clarification on the subject.
     
  3. frito1224 macrumors regular

    Joined:
    May 3, 2011
    Location:
    oklahoma
    #3
    I had this problem and I called apple they told me that the only way to do it if you can't remember the passcode for it is to reset it
     
  4. Skoal thread starter macrumors 65816

    Joined:
    Nov 4, 2009
    #4
    Strangely it never asks for the code. I flip it off and when I back up to the settings page it's back on.

    I'm guessing since I have a card on apple pay keychain is on by default to store that info. Makes sense
     
  5. crashoverride77 macrumors 65816

    Joined:
    Jan 27, 2014
    #5
    Restart your phone or try signing out of iCloud. Keychain has been a mess for months in this regard, I had exactly the same problem. It also doesn't sync properly at the moment. Hopefully when they switch from discoveryHD back to mydnsresponder this will get fixed again.
     
  6. James035 macrumors member

    Joined:
    Apr 16, 2015
    #6
    Same issue.I tried going to Keychain Options and changing my Security Code, but that didn't trigger any good behaviour.I also tried opening Keychain Access and doing first aid, but that didn't help either.
     
  7. Skoal thread starter macrumors 65816

    Joined:
    Nov 4, 2009
    #7
    Agreed, it's a mess with no clear instructions on how to troubleshoot it. The obvious things dont work. I have noticed when it works it works well but it's either all or nothing. Strange.

    I will say when I removed my card from passbook keychain turned itself off so in chalking it up to defaulting to ON if you have a CC in Apple Pay even if you don't want to use keychain. I can understand keychain is the area where the CC data is stored however I don't see why that needs to be the case. I dont want my phone saving passwords, etc. even if I do want to use Apple Pay.
     
  8. crashoverride77, Jun 17, 2015
    Last edited: Jun 17, 2015

    crashoverride77 macrumors 65816

    Joined:
    Jan 27, 2014
    #8
    Yeah just having the same problem today again it not turning off.
    There are the issues I have
    1) it stops to sync after some time
    2) it doesn't turn off as mentioned
    3) if I try to turn it on on a new device I never get the prompt to confirm on a device that has keychain enabled. Or I do get a prompt and it gets turned on but the passwords never sync over, at all so I am stuck with a turned on keychain but an empty password list.
    4) the only way I can turn it on is by using the security code thing and than it works sort of as expected. However after some time it stops syncing (point 1) and I have to start all over again with points 2-4.

    I strongly believe this has something to do with the new network thing "recoveryD" that Apple has been using since iOS 8 and Yosemite because I never had issues before. I am curious if it gets better with OS X 10.10.4 or 10.11 which both use the old "mdnsresponder" or with iOS 9 which also reverts back to the old networking protocol.

    I tried it all, resetting keychain, deleting all items etc and issues 1-3 will always happen. So tempted to get the iOS 9 beta to see if it makes a difference.
     

Share This Page