iCloud Mail Drop not working

Discussion in 'OS X Yosemite (10.10)' started by gordon1234, Oct 17, 2014.

  1. gordon1234 macrumors 6502a

    Joined:
    Jun 23, 2010
    #1
    Has anyone had trouble with the Mail Drop feature (e.g., attachments automatically uploading to iCloud instead of attaching)? I can't get it to work at all with my Gmail account (the only account I've tried it with. No matter how big a file I attach (Gmail's attachment size limit is 25MB,) it just tries to send it as a regular attachment. I've selected the box in Mail Preferences that says "send large attachments with mail drop" but it doesn't appear to do anything.
     
  2. gordon1234 thread starter macrumors 6502a

    Joined:
    Jun 23, 2010
    #2
    I did some more testing, and I think I found out the issue. It seems like the feature is far more limited than I thought. It appears to only work for specific "whitelisted" email services where Apple knows the max file size for attachments. My Google account is using Google Apps for Business. I tried setting up a throwaway gmail.com account, and it used Mail Drop properly.

    It does NOT work with my Google Apps account, nor with my office Exchange account.

    It's quite a shame. If I'm attaching a 1 GB file to an email, it's a quite reasonable assumption that regardless of my provider, it's not going to go through as an attachment. It wouldn't hurt to at least ask if I wanted to use Mail Drop…

    By the way, one of my favorite mail apps, AirMail just got a big update for Yosemite, and it actually has a much better implementation of Mail Drop. You can simply choose for every file you attach whether you want to attach it normally or using Mail Drop. Otherwise it works just like it does in Apple Mail, but you can use it for files of any size and with any mail service.
     

Share This Page