iCloud mail issue

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by BasilFawlty, Aug 12, 2013.

  1. BasilFawlty macrumors 6502

    BasilFawlty

    Joined:
    Jun 20, 2009
    Location:
    New Mexico
    #1
    Not sure if this is the right place for this question, but...

    When I sent mail to someone, in the from field when they receive the mail it says "Home" instead of my name. This even happens when I send mail to another of my mail accounts. I have looked in the preferences on my iCloud mail account but can;t see where this is controlled?

    I want the "From" field to say "First name, Last name". Anyone know how to solve this seemingly simply problem?

    Thanks
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    This is not a simple problem. There is no internet domain "first name, last name" from which legitimate email could possibly originate. Apple strictly enforces that from and reply-to fields of email must be the user name you use to log in to email, like johndoe9977@mac.com, not some vanity handle like "Doe, John". What makes this aggravating for me is if I forward all my email accounts to a "catch all" account and want to "reply as" who it was addressed to rather than giving out my mac.com email, Apple doesn't directly support this.

    One thing you could try is see if "home" is the nickname you set up for that email account. Try changing that nick name to your name and see if it still goes out saying "home". Just be aware that the raw "from:" field will always have your johndoe9977@mac.com address and not "home" or "doejohn" or whatever it happens to look like on the screen when you are composing email.

    I can't help but wonder, why is it you care what the from field says? I would suggest you sign email like you sign a letter and leave the from and to fields for the internet to use to get email to go where it belongs.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Quit Mail app and login to your acct. at icloud.com then go to the Mail section. Click the gear at the top right and go to preferences. Go to the accounts tab and in the full name field I have marked below enter whatever name you want to use. Click done and get out of icloud.com. Restart Mail app and you should now see the correct name in the sent field (from field for recipients).

    [​IMG]
     
  4. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #4
    Do you have a entry in Contacts (or Address Book on earlier versions of OS X) for "Home" that includes the email address in question? If so, this may be your problem. You may also have to go through your Previous Recipients to clear out your email address from there as well. Or it could be what Weaselboy suggests or some combination.
     

    Attached Files:

Share This Page