iCloud Mail via IMAP in Mail stopped working

Discussion in 'Mac Apps and Mac App Store' started by Taipan, Mar 3, 2013.

  1. Taipan macrumors 6502

    Joined:
    Jun 23, 2003
    #1
    Hi!

    For a few months now I have been using iCloud mail configured in mail.app as an IMAP account, not as an iCloud account. The reason for this is that I want to use a different SMTP server, so outgoing mail has a different sender address. This has worked until a few days ago.

    Now mail.app doesn't accept my user authentication and asks for a password. I have entered it several times, and I'm sure it's correct. Logging into the account via icloud.com does work, and the same settings still work on my iPad and iPhone. Console doesn't log anything, only when I use the "check connection" feature in mail.app, there's an entry that says "Mail[447]: [<_LibSasl2SASLClient: 0x7fbebc0a76b0> mechanism: PLAIN security layer: no] Failed to start the SASL connection SASL(-1): generic failure:"

    Things I have tried so far:
    - deleting password from keychain - doesn't work
    - configuring the account as an iCloud account instead of IMAP - works
    - using the same settings in a (almost) fresh ML install - doesn't work
    - using the same settings in Outlook - works
    - using p01-imap.mail.me com instead of imap.mail.me.com - doesn't work

    Any help with this would be appreciated. Thank you!

    Regards,

    Timo
     
  2. Taipan thread starter macrumors 6502

    Joined:
    Jun 23, 2003
    #2
    OK, I have now removed the "@me.com" from the username in the IMAP settings, and now it seems to work. I still don't understand why that's necessary, since it has been working like this for a long time and still does in iOS, but at least it does work now.
     
  3. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #3
    Duh, it's Apple's Mail App, plenty of problems with it, I myself had issues with it as well for no reason at all.
    But, it seems to work now for you so you're OK.

    It also might be a server side problem, they might have changed and it's quite likely they did.
     
  4. a1kim macrumors member

    Joined:
    Dec 6, 2007
    #4
    Worked for me too

    Had the same problem, and your solution did the trick. Thanks for posting it.
     

Share This Page